WEB WP office theme help :wtc:

Discussion in 'OT Technology' started by jizzmo, Feb 18, 2009.

  1. jizzmo

    jizzmo New Member

    Joined:
    Jul 9, 2008
    Messages:
    1,336
    Likes Received:
    0
    I uploaded images to my server, added a thumbnail value in custom fields pointing to the URL for the images and the slider still does not work. Everything works except the slider.

    http://www.liveinmyhell.com

    Any help? special values I need for custom fields or when i can look in the theme files to find the custom fields? :sadwavey:

    ____________________________________________________________
    Edited:

    Okay here are screenshots, of my home.php code that browning told me to edit, i used category 15 (which is the ID for my Featured category that i want to display the images on the slider of.
    [​IMG]

    Next is a screen of my Office theme options where i selected category ID 15 (my featured posts category) for the carousel

    [​IMG]

    Showing Category for featured posts had an ID of 15
    [​IMG]

    Showing the Custom Field for the thumbnails in the slider (i think this is the problem, there is no readme for the office theme giving specific custom fields...)
    [​IMG]
     
    Last edited: Feb 18, 2009
  2. jizzmo

    jizzmo New Member

    Joined:
    Jul 9, 2008
    Messages:
    1,336
    Likes Received:
    0
    Found the fix... just encase someone runs across this problem... you will want to edit the following on the home.php file:

    Code:
    <div id="slide-box">
                        <div>  
                        <?php if ($aOptions['featured-cat'] != '[B]15[/B]') { query_posts('showposts=6&cat=[B]15[/B]' . $aOptions['featured-cat']); } ?>    
                        <?php if (have_posts()) : while (have_posts()) : the_post(); $loopcounter++; ?>
                        <a href="<?php the_permalink() ?>" title="<?php the_content_rss('', TRUE, '', 25); ?>"><img src="<?php $key="thumbnail"; echo get_post_meta($post->ID, $key, true); ?>" alt="<?php the_title() ?>" /></a>                       
                        <?php if ($loopcounter % 6 == 3) { ?>
                        </div>
    
    
    where the 15 is the category ID of the post you want displayed in the slider.

    Thanks to browning for giving me half of the fix :wavey:


    After hours of looking at it... I felt like an idiot. :coolugh:
     

Share This Page