WEB WordPress Blog Issue

Discussion in 'OT Technology' started by rusbrmasas, Oct 13, 2008.

  1. rusbrmasas

    rusbrmasas New Member

    Joined:
    May 22, 2006
    Messages:
    47
    Likes Received:
    0
    Hello,

    I just installed a WordPress blog onto my web server.
    Everything has been working great except image uploads.
    I went to upload an image and WordPress told me that a directory could not be made. It then asked me if the parent's directory has the correct permissions. Via FTP, I changed the permissions of the parent directory to 777, which I am not particularly fond of.

    Does anybody know how to avoid this situation? What kind of user (owner, group, other) does WordPress think I am when I upload images via the web front end?

    Some help and clarification here would be much appreciated.

    Thanks.
     
  2. Pepsi1975

    Pepsi1975 Mod of the Year

    Joined:
    Jan 6, 2005
    Messages:
    47,590
    Likes Received:
    1
    Location:
    Detroit
    hmm, never had this problem before

    let me see what mine is set to
     
  3. drpepper

    drpepper Active Member

    Joined:
    Nov 13, 2006
    Messages:
    38,076
    Likes Received:
    2
    Location:
    San Antonio
    create and directory in wp-content named 'uploads' and chmod it to 777. you dont have to chmod your entire site just that one directory.
     
  4. rusbrmasas

    rusbrmasas New Member

    Joined:
    May 22, 2006
    Messages:
    47
    Likes Received:
    0
    Thanks, will give that a shot and see how things go.
     

Share This Page