Windows 2000 Server People Help! - DNS and Active Directory With Crashed Server

Discussion in 'OT Technology' started by Mav2005, Nov 7, 2005.

  1. Mav2005

    Mav2005 New Member

    Joined:
    Jan 22, 2005
    Messages:
    15
    Likes Received:
    0
    Alright I took over as system admin for a small company. Right before I did they ran two servers - Trust and Piedmont. Piedmont crashed due to hard drive failure and I did a complete re install of Windows 2000 server. Before the crash, Piedmont ran DNS and acted as a file server. Trust, which is still up and doing just fine also runs DNS and runs the active directory. Since I don't have Piedmont back up as a DNS server, I'm using an outside server for my secondary DNS. Primary DNS is set to Trust on all machines. If I look in the AD on Trust, I can see where Piedmont is a domain controller. I'm getting two primary serious errors in Event Viewer on Trust:

    Dynamic registration or deregistration of one or more DNS records failed because no DNS servers are available. - 5781

    No Windows NT or Windows 2000 Domain Controller is available for domain PL. The following error occurred:
    There are currently no logon servers available to service the logon request. - 5719

    I get these errors constantly all through the day. Where do I even begin with this problem? I have tried the Microsoft Knowledge Base, but nothing fixed the problems. After I re installed 2000 server on Piedmont, I have not re setup the DNS or anything. I'd basically like to put the network back to how it used to be, with Piedmont and Trust running the DNS. However, do I need to re setup P as a domain controller? If so, got any links for that? Attached is my NetDiag report for Trust also - I'm failing on DNS and trust relationship.



    Computer Name: TRUST
    DNS Host Name: trust.PL
    System info : Windows 2000 Server (Build 2195)
    Processor : x86 Family 6 Model 8 Stepping 6, GenuineIntel
    List of installed hotfixes :
    KB893803v2
    KB894320
    KB896358
    KB896422
    KB896423
    KB896727-IE6SP1-20050719.165959
    KB897715-OE6SP1-20050503.210336
    KB899587
    KB899588
    KB899591
    KB901214
    Q147222
    Q828026
    Update Rollup 1


    Netcard queries test . . . . . . . : Passed



    Per interface results:

    Adapter : Local Area Connection

    Netcard queries test . . . : Passed

    Host Name. . . . . . . . . : trust
    IP Address . . . . . . . . : xxx.xxx.x.x
    Subnet Mask. . . . . . . . : 255.255.255.0
    Default Gateway. . . . . . : xxx.xxx.x.x
    Dns Servers. . . . . . . . : xxx.xxx.x.x
    xxx.xxx.x.x


    AutoConfiguration results. . . . . . : Passed

    Default gateway test . . . : Passed

    NetBT name test. . . . . . : Passed
    No remote names have been found.

    WINS service test. . . . . : Skipped
    There are no WINS servers configured for this interface.


    Global results:


    Domain membership test . . . . . . : Passed


    NetBT transports test. . . . . . . : Passed
    List of NetBt transports currently configured:
    NetBT_Tcpip_{204D6273-B69C-4957-9129-BD398D602C07}
    1 NetBt transport currently configured.


    Autonet address test . . . . . . . : Passed


    IP loopback ping test. . . . . . . : Passed


    Default gateway test . . . . . . . : Passed


    NetBT name test. . . . . . . . . . : Passed


    Winsock test . . . . . . . . . . . : Passed


    DNS test . . . . . . . . . . . . . : Passed
    [WARNING] Cannot find a primary authoritative DNS server for the name
    'trust.PLTDOMAIN.'. [RCODE_SERVER_FAILURE]
    The name 'trust.PL.' may not be registered in DNS.
    PASS - All the DNS entries for DC are registered on DNS server 'xxx.xxx.xxx.xxx' and other DCs also have some of the names registered.
    [WARNING] The DNS entries for this DC are not registered correctly on DNS server 'xxx.xxx.xxx.xxx'. Please wait for 30 minutes for DNS server replication.


    Redir and Browser test . . . . . . : Passed
    List of NetBt transports currently bound to the Redir
    NetBT_Tcpip_{204D6273-B69C-4957-9129-BD398D602C07}
    The redir is bound to 1 NetBt transport.

    List of NetBt transports currently bound to the browser
    NetBT_Tcpip_{204D6273-B69C-4957-9129-BD398D602C07}
    The browser is bound to 1 NetBt transport.


    DC discovery test. . . . . . . . . : Passed


    DC list test . . . . . . . . . . . : Passed


    Trust relationship test. . . . . . : Failed
    [FATAL] Secure channel to domain 'PL' is broken. [ERROR_NO_LOGON_SERVERS]


    Kerberos test. . . . . . . . . . . : Passed


    LDAP test. . . . . . . . . . . . . : Passed


    Bindings test. . . . . . . . . . . : Passed


    WAN configuration test . . . . . . : Skipped
    No active remote access connections.


    Modem diagnostics test . . . . . . : Passed

    IP Security test . . . . . . . . . : Passed
    IPSec policy service is active, but no policy is assigned.


    The command completed successfully


    Here is an outline of my DNS setup right now on Trust:

    DNS
    Trust
    pltdomain
    _mscds
    dc
    _sites
    default-first-site-name
    _tcp
    _kerberos (trust)
    _kerberos (piedmont)
    _ldap (trust)
    _ldap (piedmont)
    _tcp
    _kerberos (trust)
    _kerberos (piedmont)
    _ldap (trust)
    _ldap (piedmont)
    domains
    e8ac3e.....
    _tcp
    _ldap (trust)
    _ldap (piedmont)
    gc
    _sites
    default-first-site-name
    _tcp
    _ldap (trust)
    _tcp
    _ldap (trust)
    Host File Here For Trust
    pdc
    _tcp
    _ldap (piedmont)

    Now then I have a section for _sites which includes:
    default -first-site-name
    _tcp
    _gc (trust), _kerberos(trust), _kerberos(piedmont), _ldap(trust), ldap(piedmont)

    Next section is _tcp which includes:
    _gc (trust), _kerberos(trust), _kerberos(piedmont), _kpasswd(trust), _kpasswd(piedmont), _ldap(trust), _ldap(piedmont)

    Next section is_udp which includes:
    _kerberos (trust), _kerberos (piedmont), kpasswd(trust), kpasswd(piedmont)

    And finally there is a Name Server file for trust.

    So here's a general outline:

    pltdomain
    _msdcs
    dc
    domains
    gc
    pdc
    _sites
    _tcp
    _udp

    What's wrong with my DNS? For some reason I get the feeling that's not setup correctly at all. Where do I begin with these problems? Any ideas or help?

    Thanks!
    Lance
     
  2. rogu3

    rogu3 New Member

    Joined:
    Nov 11, 2002
    Messages:
    858
    Likes Received:
    0
    Location:
    37.240000, -115.816000

Share This Page