Win XP private folders are evil.

Discussion in 'OT Technology' started by Deus Ex Aethera, Jan 25, 2004.

  1. For those following the saga of my mother's computer *cough*NOBODY*cough*, the Windows installation which had decided to commit suicide and enter a terminal reboot loop was irrepairable and had to be replaced. So now the computer has a replacement brain sitting in the WINXP folder, right alongside its dead and decaying counterpart in the WINDOWS folder.

    Now I face a different problem. Not two weeks before this catastrophic failure, my mother decided that she had incredibly secret documents on her computer that needed both an account password AND a private Documents and Settings folder (despite the fact that her account was the only on on the comp, therefore nobody could access her documents ANYWAY :bash: ), so the new installation can't access the files and the old installation can't even TRY.

    So. My question: does anybody have a fucking clue how to open a private folder in such a way that the contents are still usable when the installation of Windows that made the folder private in the first place is no longer available?
     
  2. Penguin Man

    Penguin Man Protect Your Digital Liberties

    Joined:
    Apr 27, 2002
    Messages:
    21,696
    Likes Received:
    0
    Location:
    Edmonton, AB
    Linux boot disk with NTFS filesystem support perhaps :dunno:
     
  3. randomjoker

    randomjoker Guest

    Try using DOS and if the files are corrupted(most likely will be) run a scandisk on the corrupted folder.
     
  4. CyberBullets

    CyberBullets I reach to the sky, and call out your name. If I c

    Joined:
    Nov 13, 2001
    Messages:
    11,865
    Likes Received:
    0
    Location:
    BC, Canada/Stockholm, Sweden
    and a dos bootdisk (unmodded) has access to an ntfs partition??... nope.
     
  5. Aimless

    Aimless Resident drunkey

    Joined:
    Nov 5, 2001
    Messages:
    2,534
    Likes Received:
    0
    Location:
    Wisconsin
    Hmmmmmmmm..... Is this Pro or Home? I know this tab exists for Pro, but am unsure about Home. If you right click on said unaccessible directories, then properties, security, advanced, go to the owner tab, and choose a current user does that do anything for you?

    If not, NTFS DOS for the win. Granted, this will require you to pay up or acquire it through other means which this forum will not assist you in :dunno:
     
  6. EvilSS

    EvilSS New Member

    Joined:
    Jun 11, 2003
    Messages:
    5,104
    Likes Received:
    0
    Location:
    STL
    You need to turn off simple file/print sharing and manually change the NTFS permissions. When you make a folder private, it removes administrators from the NTFS permissions on the files. The only way to reverse it is to use the advanced (read:normal) security properties. With that, you will be able to take ownership and change the permissions.

    This will get you started:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;304040

    Note that you will loose the simple login screen (name with avatar thing) so be sure you know if and what the account password you are using is.
     
    Last edited: Jan 26, 2004
  7. Aimless

    Aimless Resident drunkey

    Joined:
    Nov 5, 2001
    Messages:
    2,534
    Likes Received:
    0
    Location:
    Wisconsin
    :hs: I have the normal (un-dumbed down) security features and I can still use the Welcome Screen. I'm not sure that that is what you're talking about, but I can't think of anything else.
     
  8. EvilSS

    EvilSS New Member

    Joined:
    Jun 11, 2003
    Messages:
    5,104
    Likes Received:
    0
    Location:
    STL
    Yup. But IIRC it turns it off by default when you enable "advanced" file sharing. At least it does when I rebuild my machines.
     
  9. deemistro

    deemistro Guest

    first, go to folder options, click the VIEW tab, scroll all the way down and uncheck "use simple file sharing." once that is done, right-click any of the private folders, go to properties, click the SECURITY tab, click the ADVANCED button, then give the administrator or any user with administrator rights permission to that folder by clicking apply, and remember to check the bottom box the "replace permission entries on all..."

    that should do it.
     

Share This Page