What the fuck is wrong?

Discussion in 'OT Technology' started by Arc, Aug 10, 2005.

  1. Arc

    Arc New Member

    Joined:
    Jun 13, 2005
    Messages:
    426
    Likes Received:
    0
    Location:
    UF/SRQ
    OK so I got a new car..put my CD player in and when turned up at all the speakers would pop and distort like crazy..so I figured they were blown

    I bought a set of JL components (Iknow) and they were too deep to be mounted without too much fuss and they sounded like shit..

    I go return those and bought a set of Boston Acoustics and have them installed at teh shop...

    when I listen to it at any loud volume they distort and pop like the old factory...the shop said my HU's internal amp might be bad and recommended I get a replacement..

    I buy new HU and it still distorts and sounds like shit...

    So now I'm thinking that it is the wiring...could wiring cause this kind of problem..

    Sorry for the long post...thanks in advance.
     
  2. Brock_Landers

    Brock_Landers Jailbait FTW!!!

    Joined:
    Mar 15, 2005
    Messages:
    525
    Likes Received:
    0
    Location:
    The great plains of Canada
    If you have deck power ONLY running to the speakers, they will crackle, and sound like shit if it's turned up real loud. No power is worse than too much power. Keep the volume down, or get an amp.

    Solution, amp the fuckers.
     
  3. johnson

    johnson New Member

    Joined:
    Nov 21, 2003
    Messages:
    38,412
    Likes Received:
    0
    amp them
     
  4. Arc

    Arc New Member

    Joined:
    Jun 13, 2005
    Messages:
    426
    Likes Received:
    0
    Location:
    UF/SRQ
    ok thanks
     
  5. JRock10

    JRock10 Active Member

    Joined:
    May 25, 2005
    Messages:
    7,751
    Likes Received:
    0
    Location:
    Nashville, TN FTW
    You may have a wire grounding out ever so slightly (just enough to cause said distortion). You can't just rule out that it's shitty head unit power (although that's likely the problem). If you want to be completely thorough, try pulling the HU and run speaker wires to the speakers (just drape them across the seats, this is just some trouble shooting) and adjust the volume to the level where the problem occurs. If you still have the same issue then you can assume that your HU amp is dirty and move from there, which would be to amp the speakers.
     

Share This Page