Weird problem with hosts file

Discussion in 'OT Technology' started by CaseLogic, Oct 1, 2003.

  1. CaseLogic

    CaseLogic Longhorns - Mavs - Cowboys - Tool - 24 - Lost - Th

    Joined:
    Sep 22, 2003
    Messages:
    23,451
    Likes Received:
    0
    Location:
    Austin, TX
    I did that ad blocking trick where you add a bunch of ad sites to your hosts file as 127.0.0.1 <ad site>.

    It's been working fine up until now, but it's just not doing anything anymore. For example, I have this entry in there:

    127.0.0.1 ad.doubleclick.net

    Then I goto ad.doubleclick.net and it goes to their site, which isn't suppose to happen. And yes, I've restarted numerous times to no avail. Is there a way that maybe the hosts file has been disabled or windows is looking for a host file somewhere else now?

    This is the host file in my system32\drivers\etc folder.

    Any help would be appreciated!
     
  2. crotchfruit

    crotchfruit Guest

    step 1: tell us which OS.

    depending on your os, somewhere in the network properties is an option to enable the hosts file. this may have been turned off.
     
  3. SLED

    SLED build an idiot proof device and someone else will

    Joined:
    Sep 20, 2001
    Messages:
    28,118
    Likes Received:
    0
    Location:
    AZ, like a bauce!
    maybe post the file too.. might be an error in there
     
  4. Rob

    Rob OT Supporter

    Joined:
    Jul 6, 2002
    Messages:
    88,612
    Likes Received:
    36
    Location:
    Atlanta, GA
    Like crotchfruit said, it sounds as though windows is simply skipping the hosts file and using DNS.
     
  5. CaseLogic

    CaseLogic Longhorns - Mavs - Cowboys - Tool - 24 - Lost - Th

    Joined:
    Sep 22, 2003
    Messages:
    23,451
    Likes Received:
    0
    Location:
    Austin, TX
    I'm using WinXP. Someone told me that the hosts file needs two blank entries (so, in essence, two carriage returns) at the end of the file. Can anyone verify that?

    And also, where can I check to see if it's been disabled?
     

Share This Page