Web Interface hangs when launching applications from a Macintosh using the ICA Java C

Discussion in 'OT Technology' started by grocerylist, Jun 11, 2008.

  1. grocerylist

    grocerylist New Member

    Joined:
    Jan 18, 2006
    Messages:
    1,693
    Likes Received:
    0
    Location:
    Houston
    Totally green to MACs. I found this support article on Citrix's website.

    http://support.citrix.com/article/CTX105240

    But I'm not sure how to correct the issue. I'm not sure how to proceed. Any MAC users out there that use Citrix that have experience with this? Thanks! Here are the instructions:

    Resolution
    Disable the LiveConnect active client connection check for Apple Macintosh clients by following the instructions below or by replacing the appembedClientScript.inc file with the appropriate copy included in the attached archive MacWIJavaFix.zip.
    Instructions for Web Interface 3.x
    In the case of Web Interface 3.x this is handled by adding a special case for Safari (the 3.x supported browser).
    File: <site root>\site\include\appembedClientScript.inc
    Edit “onInit” method (line 46 - additions are italicized):
    function onInit()
    {
    window.onunload = onUnload;
    <%
    if (!sClientInfo.isSafari()) {
    %>
    if ((typeof(document.javaclient) != "undefined")
    && (typeof(document.javaclient.isConnected) != "undefined"))
    {
    connectionMethod = true;
    }
    <%
    }
    %>
    if (client=="rdp-activex") {
    if (!RdpLaunchFailed() && checkRdpClient() && initRdpClient()) {
    connectRdpClient();
    }
    }
    }
     
  2. EkriirkE

    EkriirkE Zika Xenu OT Supporter

    Joined:
    Jan 11, 2004
    Messages:
    14,799
    Likes Received:
    0
    Location:
    Dublin & San Francisco, CA
    error #1: Java

    get darwine or something and use the real ica client
     

Share This Page