VNC question

Discussion in 'OT Technology' started by gui3, Mar 5, 2008.

  1. gui3

    gui3 all the dude ever wanted was his rug back

    May 6, 2000
    Likes Received:
    i'm trying to connect my phone to my mac via VNC.

    when i have no internet connection, i just use an ad-hoc network and it connects fine.
    when i'm on my own network, i just connect to my mac's IP address and it works fine.


    when i use a USB EVDO card to connect, i can't get it to connect. it tells me the ip is something like

    now, the EVDO card's internet connection is separate from the Wifi connection. so i set up an ad-hoc network to run at the same time as the EVDO card.

    the iphone connects to the ad-hoc connection, but can't connect to the computer. the mac is telling me i have to connect to the verizon IP, not the ad-hoc ip.

    SO MY QUESTION is: what can i do to keep the EVDO connection separate from the ad-hoc wifi network for the purposes of VNC?
  2. IcyHot4Life

    IcyHot4Life Str8 Ballin'

    Aug 2, 2002
    Likes Received:
    Inquire Within
    okay, when you're set up in this scenario, what other services are you able to access on your mac, from your iphone? does it respond to ping over the ad-hoc address? if you enable web sharing, can you view the default apache page for the mac?

    You shouldn't have to segregate the network connections for VNC to work, unless some weird shit is happening where the VNC server is binding exclusively to the interface that presents a gateway (which it might be, though that's rather weird) :dunno:

    I assume this is the built-in VNC server?

    P.S. due to the nature of the problem, a few screenshots of the setup might be helpful. Also, once your networks are set up, take a screencap of the terminal window; unless you've changed the way the prompt works it should reflect the domain name of the node you are connected as. If the EVDO connection takes precedence, this will be something at or whatever.
    Last edited: Mar 7, 2008

Share This Page