Terminal Problems =(

Discussion in 'OT Technology' started by ez4me2c3d, Aug 31, 2007.

  1. ez4me2c3d

    ez4me2c3d Cold Member

    Joined:
    Sep 19, 2003
    Messages:
    1,836
    Likes Received:
    0
    Location:
    Minneapolis, MN
    I was trying to install Dynamips, and now my terminal is auto running some dynamips commands everytime I open a term window.

    Is there a file somewhere I can look at to modify this setting?
     
  2. lowfat

    lowfat 24/Mac/SciFi/PC Crew OT Supporter

    Joined:
    Oct 27, 2003
    Messages:
    63,949
    Likes Received:
    0
    Location:
    Grande Prairie, AB, Can
    Are you opening up terminal directly from the Utilities folder?
     
  3. ez4me2c3d

    ez4me2c3d Cold Member

    Joined:
    Sep 19, 2003
    Messages:
    1,836
    Likes Received:
    0
    Location:
    Minneapolis, MN
    that is correct
     
  4. hurleyint1386

    hurleyint1386 Someone has sand in their vagina

    Joined:
    Jan 6, 2005
    Messages:
    3,687
    Likes Received:
    0
    Location:
    Rochester, NY
    see if you can hit Ctrl+C really quick before it closes so it'll stop what it's doing. or if not, try Ctrl+Z to make the process sleep
     
  5. ez4me2c3d

    ez4me2c3d Cold Member

    Joined:
    Sep 19, 2003
    Messages:
    1,836
    Likes Received:
    0
    Location:
    Minneapolis, MN
    Good tip but I figured it out before I could try that Ctrl+C thing.

    Here's how to modify it:

    The Terminal can be setup to launch commands at startup.

    This is done through the com.apple.Terminal.plist found at:
    /users/you/Library/Preferences/

    But you have to have this program to modify it:
    http://www.apple.com/downloads/macosx/development_tools/plisteditpro.html

    Edit the 'ExecutionString' variable to be what ever commands you want separated by a semi-colon ( ; )

    Mine was set to run some program that kept crashing and closing the terminal.

    Cheers :beer:
     

Share This Page