System Set Up, what's wrong?

Discussion in 'OT Technology' started by Reverand Jonas, Nov 22, 2004.

  1. Reverand Jonas

    Reverand Jonas Tool > *

    Joined:
    Nov 10, 2004
    Messages:
    1,152
    Likes Received:
    0
    Location:
    desert
    I just want to throw this out for some advice...

    My buddy has a system in his car that just blows the shit out of mine.
    He is running a Pioneer deck, a 1 farad cap, 1 900 watt mono rockford fosgate amp, and 2 10 inch HE2s. In a Chevy caviler

    I have a kenwood deck, 2 900 watt mono amps, and 2 12 inch DVC volfenhag subs. in a gmc sonoma extended cab

    Any comments and advice would be great.
     
  2. Elderain

    Elderain New Member

    Joined:
    Aug 10, 2004
    Messages:
    3,694
    Likes Received:
    0
    Location:
    Florida, Clearwater
    It's not always about size and watts. Quality means alot too. Your subs might take 2x the power but might be inefficent as hell. What type of box do you guys have? If your box is shitty it will make a differece too.
     
  3. Reverand Jonas

    Reverand Jonas Tool > *

    Joined:
    Nov 10, 2004
    Messages:
    1,152
    Likes Received:
    0
    Location:
    desert
    They are both sealed. His is a q-logic and i made mine. I dont know the dimentions of his, but mine are 14x14x14 for each spearer.
     
  4. twistid

    twistid Banged By Super Models Moderator

    Joined:
    Jul 15, 2001
    Messages:
    40,849
    Likes Received:
    112
    Location:
    The Kansass/Oklahomo Border
    could be the installs, could be your equipement, but it could also be because of the cars... j-bodies sound very well in my expirence.
     

Share This Page