Stupid JL RBC-1 (remote bass control) BROKE!!!

Discussion in 'OT Technology' started by Audiophile, Oct 12, 2002.

  1. Audiophile

    Audiophile boom boom

    Joined:
    Sep 22, 2002
    Messages:
    2,023
    Likes Received:
    0
    Location:
    Ephrata, PA
    here i waited 2 weeks to get my RBC-1 from the local dealer and i took it home to attatch to my JL 500/1. it says remove the knob to mount, but it doesnt say how to remove the knob. so i assumed you screw it off :dunno: , and i tried....wouldnt budge, so i grabbed one of those grib things you use to open jars and then it came off...along with the rod that is attatched to the inside :uh: , i can put the rod back in but it jus turns freely and doesnt adjust the gain at all, if i plug the wire into the amp the bass goes way up because i when it broke off it was up all the way

    has anyone ever encountered this same problem?!?

    now i have to send it back to JL and they fix it and send it baaack to me, hopefully this wont take forever

    -Austin
     
  2. Audiophile

    Audiophile boom boom

    Joined:
    Sep 22, 2002
    Messages:
    2,023
    Likes Received:
    0
    Location:
    Ephrata, PA
    anyone?
     
  3. 04

    04 Guest

    Well you said that you broke it?

    I would assume that you should send it back to get it fixed.

    You could first try to find out what the device is. If it is something simple like a rheostat you could probably find a replacement item. However, I would guess that it is a propietary design.
     

Share This Page