Stuck need help

Discussion in 'OT Technology' started by jackback52, Jul 12, 2006.

  1. jackback52

    jackback52 Guest

    I bought a copy of office 2004 student teacher edition and installed with no problems on my iMac G5. Microsoft just released an update and I can't seem to be able update the programs.

    The installer gives me the error "The installer could not locate the correct version of the sofware required to install this update"

    I have meet all the requirements and ahve tons of memory & now I'm stumped and need help

Share This Page