Server Help. Can't Map to WIN2003 shared folder via Windows 7

Discussion in 'OT Technology' started by Firehawk, Dec 19, 2009.

  1. Firehawk

    Firehawk OT Supporter

    Joined:
    Jul 26, 2005
    Messages:
    1,983
    Likes Received:
    0
    Location:
    Kansas City, MO
    My Server: (\\SERVER)
    Windows 2003 Server Enterprise Edition (VMware on Windows XP x64)
    Apache 2.2.14, PHP 5.3.1, MySQL 5.1.14

    My Desktop: (\\ERIC-PC)
    Windows 7 Professional x64

    My Laptop: (\\ERIC-LAPTOP)
    Windows Vista Home x86

    I've got my Server almost configured the way I want it. It's a application server in my networks DMZ.
    - Friends can connect to it via it's public IP on port 8080. (My ISP blocks port 80)
    - I can remote in using remote desktop as well as connect to MySQL via MySQL Administrator
    - I've mapped a drive to my \\SERVER\apache\htdocs on my LAPTOP so that I can edit via the mapped network drive and not deal with FTP.
    - I tried to map to my \\SERVER\apache\htdocs on my DESKTOP and it's giving me the error "You do not have permission to connect to \\SERVER."
    When I type in my servers IP as \\192.168.x.x in my computer it shows me this:
    [​IMG]
    NOTE: Under Domain, ERIC-PC is the computer name of my network.
    I've tried using my current computers name login name and password as well as my server's login info.

    - All computers (Desktop, Laptop, Server are in the workgroup "Workgroup"
    - I have mapped a drive to my desktop from my server as "\\ERIC-PC\Public\" and currently make changes by remoting into the server and copying from that mapped drive to my apache\htdocs folder.

    Everything pings fine, and I've tried disabling the windows firewall.
     
  2. XR250rdr

    XR250rdr OT Supporter

    Joined:
    Mar 1, 2004
    Messages:
    24,488
    Likes Received:
    22
    Location:
    Ca
    Go to Network and Sharing Center -> Advanced Sharing Settings -> <active network> -> Check "Turn on File and Printer Sharing"
     
  3. Fase

    Fase Your Face, In A Pickle Jar.

    Joined:
    Apr 6, 2004
    Messages:
    29,540
    Likes Received:
    0
    Location:
    Windsor, Ont, Canada.
    .
     
  4. Hate Crime

    Hate Crime Don't Hate OT Supporter

    Joined:
    Mar 12, 2006
    Messages:
    5,255
    Likes Received:
    0
    Location:
    Minnesota
    Are you using the same username(administrator, or something else?) on the windows 7 PC as you are on server 2k3?
     
  5. Firehawk

    Firehawk OT Supporter

    Joined:
    Jul 26, 2005
    Messages:
    1,983
    Likes Received:
    0
    Location:
    Kansas City, MO
    It is. Windows Firewall exception added as well.

    Nope.
    Username on Windows 7 is Eric
    Username on Windows 2003 Server is Administrator
     
  6. peerk

    peerk New Member

    Joined:
    Mar 14, 2005
    Messages:
    984
    Likes Received:
    0
    Have you tried putting "servername\username" in the username box?
     
  7. Firehawk

    Firehawk OT Supporter

    Joined:
    Jul 26, 2005
    Messages:
    1,983
    Likes Received:
    0
    Location:
    Kansas City, MO
    When I do that that changes the Domain from Eric-PC to blank.

    UserName: \\SERVER\Administrator
    PW: Administrator's Password

    Error: "\\192.168.1.148 is not accessible. You may not have permission to use this network resource."
     
  8. Hate Crime

    Hate Crime Don't Hate OT Supporter

    Joined:
    Mar 12, 2006
    Messages:
    5,255
    Likes Received:
    0
    Location:
    Minnesota
    Have you turned off simple file sharing and rebooted?
     
  9. Firehawk

    Firehawk OT Supporter

    Joined:
    Jul 26, 2005
    Messages:
    1,983
    Likes Received:
    0
    Location:
    Kansas City, MO
    What do you mean by simple file sharing? Which computer?
     
  10. Firehawk

    Firehawk OT Supporter

    Joined:
    Jul 26, 2005
    Messages:
    1,983
    Likes Received:
    0
    Location:
    Kansas City, MO
    Ok so I did this:

    Administrative Tools => Local Security Policy.
    "Security Settings" => "Local Policies" => "Security Options"

    Network security: Sharing and security model for local accounts
    => Guest only - local user authenticate as Guest
    Accounts: Guest account status
    => Enabled

    Now when I type \\SERVER I can see my shared folder "htdocs" but not view it.

    www is my "htdocs"

    [​IMG]

    [​IMG]
     
    Last edited: Dec 20, 2009
  11. Fase

    Fase Your Face, In A Pickle Jar.

    Joined:
    Apr 6, 2004
    Messages:
    29,540
    Likes Received:
    0
    Location:
    Windsor, Ont, Canada.
    Add Sharing permissions and security permissions for an account.

    Connect as:
    SERVER\accountname
    password
     
  12. Firehawk

    Firehawk OT Supporter

    Joined:
    Jul 26, 2005
    Messages:
    1,983
    Likes Received:
    0
    Location:
    Kansas City, MO
    Tried it using both Administrator and another account.
     
  13. AbortionSurvivor

    AbortionSurvivor Active Member

    Joined:
    Jun 5, 2002
    Messages:
    3,016
    Likes Received:
    0
    Location:
    Nor. Cal
    Just wondering, but do you have any Norton products installed on your windows7 machine? Or any 3rd party firewall?
     
  14. Fase

    Fase Your Face, In A Pickle Jar.

    Joined:
    Apr 6, 2004
    Messages:
    29,540
    Likes Received:
    0
    Location:
    Windsor, Ont, Canada.
    Could it be some apache security setting preventing you from remotely accessing the folder?
     
  15. Firehawk

    Firehawk OT Supporter

    Joined:
    Jul 26, 2005
    Messages:
    1,983
    Likes Received:
    0
    Location:
    Kansas City, MO
    nope.
     
  16. Firehawk

    Firehawk OT Supporter

    Joined:
    Jul 26, 2005
    Messages:
    1,983
    Likes Received:
    0
    Location:
    Kansas City, MO
    I'll look into the idea. I might mention it to the server administrator at work (I'm a student developer at my school) and see if he has any ideas. Though we currently use IIS at work. :hsugh:
     
  17. Hate Crime

    Hate Crime Don't Hate OT Supporter

    Joined:
    Mar 12, 2006
    Messages:
    5,255
    Likes Received:
    0
    Location:
    Minnesota
    You have added "everyone" with full control on the NTFS share too?
     
  18. Firehawk

    Firehawk OT Supporter

    Joined:
    Jul 26, 2005
    Messages:
    1,983
    Likes Received:
    0
    Location:
    Kansas City, MO
    what do you mean NTFS share? I just have the one folder shared.
     
  19. Hate Crime

    Hate Crime Don't Hate OT Supporter

    Joined:
    Mar 12, 2006
    Messages:
    5,255
    Likes Received:
    0
    Location:
    Minnesota
    The "Security" tab on the directory you shared should have "everyone" in it with full access.
     
  20. hay112

    hay112 For every sprinkle I find I shall kill you

    Joined:
    Mar 8, 2001
    Messages:
    4,837
    Likes Received:
    0
    this seems really stupid but i as you see windows 7 always uses the local pc as to what your logging into as you showed in the picture. The workgroup or domain should always be in front of the user name. So if your workgroup is called "WORKGROUP" just use "WORKGROUP/eric" or whatever the user name is
     
  21. DigiCrime

    DigiCrime If Only!

    Joined:
    Oct 25, 2001
    Messages:
    33,014
    Likes Received:
    101
    Location:
    St. Louis
    Both the server/computer have the same gateway and dns? Dumb I kno but overlooked a lot of times. Windows 7 seems to have trouble accessing folders on Windows 2003 if the security tab doesn't have the same as share permissions as well. check into that
     
  22. Hate Crime

    Hate Crime Don't Hate OT Supporter

    Joined:
    Mar 12, 2006
    Messages:
    5,255
    Likes Received:
    0
    Location:
    Minnesota
    :confused: Every OS does.
     
  23. DigiCrime

    DigiCrime If Only!

    Joined:
    Oct 25, 2001
    Messages:
    33,014
    Likes Received:
    101
    Location:
    St. Louis
    Well yea true.. some of the systems my clients are moving to Win7 Pro and have a hard time pulling up some of the shared folders over mismatch security and permissions. Just something I had been noticing. For example if everyone was on the tab then XP systems can access it, put guests on there along with everyone windows 7 couldn't see it. Take off everyone but leave guests windows 7 can see/read :dunno:
     
  24. JayWang

    JayWang OT Supporter

    Joined:
    Dec 29, 2004
    Messages:
    5,882
    Likes Received:
    1
    Location:
    Calgary, Alberta
    subbing
     
  25. deusexaethera

    deusexaethera OT Supporter

    Joined:
    Jan 27, 2005
    Messages:
    19,712
    Likes Received:
    0
    What version of Windows 7 are you using? Home, Professional, Ultimate? Pro and Ultimate should work fine, Home, I dunno. Home probably has dumbed-down network file sharing settings that could be getting in the way.

    Anyway, whatever user account you're logged in with, the same user account needs to exist on the file server, and it needs to have the same password. A Windows domain would sync usernames and passwords automatically, but without a domain you have to do it manually.

    Make sure the shared folder has Security permissions and Sharing permissions set appropriately. Go to the folder's Sharing tab and set the permissions to "Everyone => Full Access", then go to the Security tab and get more detailed from there. The fact that you have to set Security permissions and Sharing permissions is fucking retarded, so I just keep it simple and let anyone access the share, but only certain user accounts can actually list/read/edit the files therein.
     

Share This Page