Resetting Permissions on a Network Drive?

Discussion in 'OT Technology' started by silentak1, Aug 12, 2007.

  1. silentak1

    silentak1 New Member

    Joined:
    Jun 14, 2005
    Messages:
    45
    Likes Received:
    0
    Resetting Folder/File Permissions on a Network Drive?

    Hello,

    I have a big problem. We use to use a computer (named "Fileserver") to share and access files within a few computers, but XP only allowed a max of 10 connections. So then I bought a Simpletech 250gb network drive (FAT32, Y:) and plugged it into the router. I transferred all the files into that network drive and disabled the "Fileserver" access. Now, during this transfer process Windows XP Pro wouldn't let me transfer from folders; it gave me an error of "Can't copy or move".

    I played with the permissions to give Admins and Everyone full control, but Windows still wouldn't allow me to transfer folders. The funny thing is that I could transfer files inside that folder, but I couldn't transfer the entire folder at once. Get it? And so I did it that way, and now whenever people try to access THOSE files, they have denied access. The rest of the files are fully accessible.

    For example, in MS Word 07 they get this error:
    "The document name or path is not valid. Try these suggestions.
    *Check the file permissions for the document or drive.
    *Use the File Open dialog box to locate the document."


    How can I reset the folder/file permissions on a network drive so all the files are accesible? Or is there a better solution? I've tried the subinacl.exe file, but it only changes permissions on the computer that I'm running it and not on the network drive (Y:).

    Really need help with this!!!!!! Thank you in advanced for your help!

    silentak1
     
    Last edited: Aug 12, 2007
  2. deusexaethera

    deusexaethera OT Supporter

    Joined:
    Jan 27, 2005
    Messages:
    19,712
    Likes Received:
    0
    Change permissions on the root of the drive, then click the "Advanced" button and check the checkbox that says "Apply these permissions to all child items".
     
  3. silentak1

    silentak1 New Member

    Joined:
    Jun 14, 2005
    Messages:
    45
    Likes Received:
    0
    Hello,

    Thank you for the suggestion, but it didn't solve the problem. Perhaps more details from me would help.

    Original Situation:
    People would access files from a computer we call "Fileserver". It was just a plain old shared folder under Windows XP (NFTS), with permissions Full Control permissions for admins, fileserver/users, and partial (r/w) for 'everyone'. Since XP only allows 10 computers to access "fileserver" we decided to find another solution.

    The solution we bought:
    Bought an iNOI HD363N NAS (FAT32) network harddrive, connected it to the network hub, and ran setup without a glitch. Created a folder in the NAS and copied all the files from "fileserver" to "NEW_fileserver". During the process process of transferring from the XP NFTS computer to the Network Drive, some folders couldn't be copied. Windows would just plainly say "Can't Write" or "Can't Copy". However, if I opened those folders I was allowed to copy the files inside the folder. In other words, I couldn't copy the entire folder at once but I could copy all the files inside of that folder at once. Strange, no?

    The aftermath problem:
    Now that all the files are in the new network drive (FAT32), people can see the files, but are unable to access it. For instance, whenever I open any word document, Word says "Can't open file, check file permissions or root path" (something along those lines).

    My guess of the problem:
    -Could it be that the permissions are wrong? Should I have set FULL CONTROL permissions for EVERYONE BEFORE transferring all the files to the new fileserver? When I right click on the network harddrive folders or files to go to properties, I don't see a "security" tab where I could modify permissions.
    -Another guess, could the files somehow have gotten corrupted over the transfer from XP to NAS? Most files open, except the folders that were giving me a hard time copying.

    Do any of you have any idea how I can go about fixing this issue?

    I truly thank you all in advance for taking your valuable time to help me out.

    silentak1
     
  4. peerk

    peerk New Member

    Joined:
    Mar 14, 2005
    Messages:
    984
    Likes Received:
    0
    I'm pretty sure the security tab is only there for NTFS drives.

    You probably need to log into the drive(web based?) and configure some settings there.
     
    Last edited: Aug 14, 2007

Share This Page