Radeon 9500/9700 Cat3 Truform guide

Discussion in 'OT Technology' started by durondude, Jan 28, 2003.

  1. durondude

    durondude OT Addict

    Joined:
    May 7, 2001
    Messages:
    24,061
    Likes Received:
    5
    Location:
    Earth, The Planet
    First of all my system specs:
    Athlon 900mhz 512MB PC133
    Windows XP Pro SP1
    Radeon 9500 -> 9700 via RivaTuner SoftRadeon No-OC
    --------------------------
    .. try at your own risks
    .. The Truform implementation in the current drivers are slow.
    .: Now for the good stuff
    First of all, it seems the truform option in the
    ATI control panel has been removed. No problem,
    just fire up 'regedit', and search for 'Truform'
    without the single-quotes. The search should return
    a fair amount of results. Remember to change the ones
    that says 'TrueformMode' also.

    Changes needed:
    . Trueform
    '0' -> '1'
    '00 00 00 00' -> '01 00 00 00'

    . TrueformMode
    '0' -> '1'
    '0x000000' -> '0x000001'

    .: Games
    . Half-Life / CS
    - Make sure you have the latest patch.
    - Open up the console (usually '~')
    - Type these commands without the quotes (no particular order):
    -- 'ati_npatches x' <- (x = 1 enable Truform, x = 0 disable Truform)
    -- 'ati_subdiv x' <- (Truform level, x = 2 default, x = 7 Max I think)
    - I noticed a big performance hit
    - fps went from 70fps -> 45fps when Truform was enabled with the default setting.

    . Return to Castle Wofenstein
    - It's always good to have the latest patch installed. (Truform support OoTB)
    - Run the game.
    - 'Options' -> 'System' -> 'Graphics'
    - Move mouse down to the bottom.
    - Click Truform to enable it.
    - Click apply.
    - Exit the options menu.
    - Go back in 'Options' -> 'System' -> 'Graphics'
    - If you edited the write values in your registry the Trueform option should still be on.
    - If not, go back, check your values in your registry.
    - Haven't figured out how or if you can change the Truform level but the default looks good enough.
    - I didn't notice any peformance hit at all.

    . Unreal Tournament 2003
    - It's always good to have the latest patch installed. (Truform support OoTB)
    - Fire up 'UnrealEd' (Unreal Editor)
    - Goto menu item 'View' -> 'Advance Options'
    - A new window should have popped up.
    -- Expand 'Rendering' down at the bottom.
    -- Expand 'Direct3d support'
    -- Scroll down to where you see 'UseNPatches'
    --- Set 'UseNPatches' to 'True'
    - Close the window.
    - Close UnrealEd.
    - Looks good for me!
    - I did not experience any performance hit.

    Keep in mind that my CPU is probably limiting some of these games.
    UT2k3: 40-50fps
    CS 1.6: 70fps w/o Truform, around 40-50 w/ Truform
    RTCW: 70fps w/o Truform, around 60fps w/ Truform


    I hope this will help to clear up some questions regaurding truform with the Radeon 9500/9700 series.

    Feel free to add more intructions or clear up any mistakes I've made.
     

Share This Page