PSU goes boom

Discussion in 'OT Technology' started by DemisE, Oct 20, 2004.

  1. DemisE

    DemisE Active Member

    Joined:
    Oct 17, 2003
    Messages:
    6,337
    Likes Received:
    0
    Location:
    Memphass
    So I am sitting in the other room watching the debate and I hear a really loud POP!. Thinking that my cats broke something I get up and go investigate. Walk into the office and smell that scent that nobody wants whiff of. Electricals Burning.

    Quickly I check my PC, looks ok, servers look good, hrm..

    I think look at my fiances PC that is now off. Didn't think much of it untill she comes in asking why her PC is off and what is that nasty smell! :eek3:

    Pull the cover off and the smell just rolls on out so I know that something has gone very wrong. Take the cables off the back and start to investigate. Everything "looks" ok so I start the sniff components routine.

    CPU, HDD, CD-ROM, FANS, Video - Check
    PSU - :mad:

    Yanked the PSU and opened it up and saw that I found the culprit.

    [​IMG]
    [​IMG]

    So what else to do but throw the bastard in the floor and curse at it.

    [​IMG]

    Not really thinking anything of it I decided to slap in a new PSU and she will be back up and running. I had a Ultra X-Connect that I have had waiting for my new case setup but it got drafted into service earlier than anticipated. Do a PSU swap on my rig and hers knowing that my current PSU is good to go.

    But the damn thing won't power on, Soon as I hit the power button the fans jump and then die. No Glory :mad:

    More investigation. Now fully pissed that I missed the brunt of the debate I tear down her whole rig to see if the PSU going killed the MoBo. Along the way I find something else.
    Sound Cards are not supposed to have afro's

    [​IMG]
    [​IMG]

    Time to talk bad about someones momma yet again.

    [​IMG]

    After careful inspection of all other components nothing else looks to be damaged. But the system will not power on even with just the MoBo plugged into the PSU. I am guessing that since the sound card died that a surge came through the MB and killed it. So I will assume that the MB is dead.
     
  2. gutterslide

    gutterslide Guest

    wow. that really sucks. thanks for the illustration, though. :bigthumb: i didn't expect a blown cap to look like dandelion fluff.
     
  3. oradii

    oradii www.oteampress.com

    Joined:
    Jul 12, 2004
    Messages:
    779
    Likes Received:
    0
    Location:
    ATL
    the ..i.. pics are the best!

    and yeah, yo mb es probably toast
     
  4. lowfat

    lowfat 24/Mac/SciFi/PC Crew OT Supporter

    Joined:
    Oct 27, 2003
    Messages:
    63,949
    Likes Received:
    0
    Location:
    Grande Prairie, AB, Can
    that truly sucks. but thats for the comic relief.
     
  5. percent

    percent deluded

    Joined:
    Jan 5, 2004
    Messages:
    12,371
    Likes Received:
    0
    Location:
    The Desert West
    someone one has never been building circut and installed a cap backwards :o
     
  6. unrealii

    unrealii professor of plant biology

    Joined:
    May 6, 2001
    Messages:
    2,037
    Likes Received:
    0
    Location:
    So CALI
    I can't tell, is that a generic or brand name psu? Sucks about the computer :(
     

Share This Page