problems with fresh install

Discussion in 'OT Technology' started by $shot, Dec 17, 2004.

  1. $shot

    $shot OT Supporter

    Joined:
    Oct 30, 2004
    Messages:
    6,048
    Likes Received:
    0
    Location:
    Morgantown
    i have 2 hds, a 74gb SATA 10k raptor and 120gb 7200. i just formatted/installed xp pro on my main drive (the raptor), and when i boot up w/out the winxp pro cd in, i get this error while trying to boot, "NTLDR is missing ... Press Ctrl+Alt+Del to restart." if i put the xp cd in, it skips that then i have to choose between what OS to use, XP Pro or XP Pro (they're the same thing, pretty sure they both use the raptor). xp eventually boots fine and i can read my 120gb drive fine.


    any ideas? i have no clue what that error means
     
  2. cmsurfer

    cmsurfer ºllllllº

    Joined:
    Jun 6, 2003
    Messages:
    5,079
    Likes Received:
    0
    Location:
    NJ
    The error means that ntldr is missing or corrupt.

    You can boot off the CD and go into the recovery console to fix it. I think you need to use the bootcfg /rebuild command to rebuild the boot.ini file. You may want to run a google search to make sure on the command to use.
     
  3. $shot

    $shot OT Supporter

    Joined:
    Oct 30, 2004
    Messages:
    6,048
    Likes Received:
    0
    Location:
    Morgantown
    if i have a new hd and new xp pro cd, why is this happening? it worked fine the first time i did it.. also, is there any way to label my main hd back to c:\? it got changed to d: after the format, and the backup is c:\
     
  4. AccidenT

    AccidenT Remember I will always love you, as I claw your fu

    Joined:
    Oct 2, 2000
    Messages:
    1,880
    Likes Received:
    0
    Location:
    Portland, ME
    It sounds like the main drive isn't set to the primary master and/or isn't in the list of boot devices in the BIOS settings.
     
  5. Slid.

    Slid. I'm a guy.

    Joined:
    Oct 25, 2001
    Messages:
    1,928
    Likes Received:
    0
    Location:
    NH
    As for getting the raptor to be c: you could leave the IDE drive out while installing windows. SATA drives have no master/slave settings as you know, if the IDE is set to master try setting it to slave under a cdrom or something.

    I am pretty sure my IDE is a master on its own ide cable and my sata (a raptor also) is seen as c: but I installed windows with only the raptor plugged in.
     
  6. $shot

    $shot OT Supporter

    Joined:
    Oct 30, 2004
    Messages:
    6,048
    Likes Received:
    0
    Location:
    Morgantown
    my first installed it was c:\.. before i formatted i accidently reversed the drive letters, so i'm assuming there's a way to change them back w/out formatting again
     
  7. Slid.

    Slid. I'm a guy.

    Joined:
    Oct 25, 2001
    Messages:
    1,928
    Likes Received:
    0
    Location:
    NH
    You can change drive letters after the fact in XP, you do this by going Control Panel->Admin. Tools->Computer Management->Storage->Disk Management.

    I just tried and it does seem to let you change the letter of the drive with the Windows install on it but I'd be concerned with it corrupting the system if you do.

    Some things installed may look for D:\Program Files\, etc. and they won't be there anymore.
     
  8. Yep

    Yep Knick knack paddy whack, give the old dog a bone

    Joined:
    Jan 22, 2001
    Messages:
    4,603
    Likes Received:
    0
    Location:
    South Jersey
    Check the boot.ini file.
     
  9. $shot

    $shot OT Supporter

    Joined:
    Oct 30, 2004
    Messages:
    6,048
    Likes Received:
    0
    Location:
    Morgantown
    i copied ntldr and ntdetect.com off my winxp cd onto my c:\ and it worked, but i then had problems w/ my boot.ini and my drive labels were still screwed up..

    solution: i formatted again, however, this time i unplugged my backup hd during the format and fresh install of xp pro, and didn't plug it back in until everything was installed on my raptor. everything back to normal including the drive labels. thanks for the help!
     

Share This Page