photoshop elements 6 help

Discussion in 'OT Technology' started by gameover, Jun 11, 2008.

  1. gameover

    gameover New Member

    Joined:
    Mar 17, 2008
    Messages:
    22
    Likes Received:
    0
    Hey guys i had a demo version and it ran out, so i use a torrent off of demonoid and i'm getting this error when i try and install.

    JavaScript Alert

    Critical errors were found in setup
    - Incompatible payloads already installed
    Please see the Setup log file for details.

    What should i do, i also have a demonoid invite if someone needs one.

    -joey
     

Share This Page