Older printers on 10.4

Discussion in 'OT Technology' started by asiandoood, May 4, 2005.

  1. asiandoood

    asiandoood New Member

    Joined:
    Sep 14, 2004
    Messages:
    209
    Likes Received:
    0
    Location:
    norcal
    Well..Im trying to print off my older Epson oversize printer (epson stylus 1520). Problem is all the drivers are running OS9 and older. Tiger doesnt seem to be finding any compatible drivers...and Epson does not have an update for OSX for this printer. Am I SOL on this?

    system: Dual 1.8 G5
    OS: 10.4 Tiger
    printer: Epson Stylus 1520 USB.


    thanks in advance for any help.
     
  2. Do you have the GIMP drivers installed? Did you check the manufacturer's website for a compatible driver?
     
  3. asiandoood

    asiandoood New Member

    Joined:
    Sep 14, 2004
    Messages:
    209
    Likes Received:
    0
    Location:
    norcal
    Already checked manufacturer's website for driver updates. It only goes up to OS8.


    I used the GIMP drivers which was unsuccessful. I uninstalled that also.
     
  4. jackjohnson

    jackjohnson simple as something nobody knows OT Supporter

    Joined:
    Apr 5, 2002
    Messages:
    40,863
    Likes Received:
    0
    Location:
    Southern California
    did you try installing it in classic mode
     
  5. asiandoood

    asiandoood New Member

    Joined:
    Sep 14, 2004
    Messages:
    209
    Likes Received:
    0
    Location:
    norcal
    for some reason... when i upgraded to 10.4, it cannot find classic :dunno:
     
  6. jackjohnson

    jackjohnson simple as something nobody knows OT Supporter

    Joined:
    Apr 5, 2002
    Messages:
    40,863
    Likes Received:
    0
    Location:
    Southern California
    hmm how did you upgrade. i did a clean auto install and i have classic. i would try that
     
  7. asiandoood

    asiandoood New Member

    Joined:
    Sep 14, 2004
    Messages:
    209
    Likes Received:
    0
    Location:
    norcal
    i did a clean install too. :dunno: i must of missed it b/c i did the custom install.... grr.
     
  8. asiandoood

    asiandoood New Member

    Joined:
    Sep 14, 2004
    Messages:
    209
    Likes Received:
    0
    Location:
    norcal
    well..looks like i have to work in 10.4, transfer my files to my PB (running OS9) and print from there. the printer is wide format (17x22) and has to use the Epson drivers which arent availible for OSX and Adobe CS :mad: ....
     

Share This Page