New Sti broken?

Discussion in 'OT Driven' started by errorunknown, Jul 25, 2007.

  1. errorunknown

    errorunknown New Member

    Joined:
    Mar 11, 2007
    Messages:
    293
    Likes Received:
    0
    So I traded in my Si and went for an 07 Sti! I got tired of the Si's lack of torque and couldn't handle it anymore. There is one problem though... On my way home from the dealer I hit the redline a couple times, but there was no vtec!!! Is there something wrong with my car? Should I go back to the dealer or is it something I can fix? :noes:
     
  2. Rich

    Rich New Member

    Joined:
    Jun 26, 2007
    Messages:
    5,225
    Likes Received:
    0
    Location:
    Orlando, FL
    Noob
     
  3. E-dub

    E-dub New Member

    Joined:
    May 17, 2007
    Messages:
    318
    Likes Received:
    0
    404 funny not found

    Shoulda bought an '05, those '07's are hideous.
     
  4. NomadicPants

    NomadicPants Subaru > *

    Joined:
    Aug 13, 2006
    Messages:
    1,662
    Likes Received:
    0
    Location:
    Littleton, CO/Houston, TX
  5. Vicious-S

    Vicious-S New Member

    Joined:
    May 7, 2006
    Messages:
    495
    Likes Received:
    0
    Location:
    Orygun
    Si has more torque than a flat four.
     
  6. Ronin

    Ronin Guest

  7. ///M

    ///M New Member

    Joined:
    Jan 3, 2006
    Messages:
    45,246
    Likes Received:
    0
    Location:
    WA
  8. Drifter87

    Drifter87 Yippi-kay-ay, Motherfucker

    Joined:
    Jan 5, 2005
    Messages:
    7,173
    Likes Received:
    0
  9. ANUS_MANGLER

    ANUS_MANGLER New Member

    Joined:
    Dec 3, 2006
    Messages:
    6,961
    Likes Received:
    0
    Location:
    St. Louis
    better hurry back and see if they will trade you back the torque monster


    :hsugh:
     
  10. goaliekeg

    goaliekeg New Member

    Joined:
    Jun 18, 2007
    Messages:
    5
    Likes Received:
    0
    Is this guy serious? Go trade your STi back in for the Si...you don't deserve it.
     
  11. Uh yeah he is serious :hsugh: have you noticed all the :ugh: smileys. :ugh2:
     
  12. LongDongWong

    LongDongWong U can call me Mr.Wong

    Joined:
    Oct 24, 2001
    Messages:
    2,293
    Likes Received:
    0
    Location:
    Bay Area
    Your car must still be really new or the dealer didnt properly break the engine in for you.....take the car out and drive it around the block to warm it up....one of the disadvantages of not having a honda......once you have driven around the block
    - pull into the driveway put it into neutral
    -rev it twice
    -on the third rev of the engine ****next step very important for V-tec to work properly

    -keep it at redline for 5 minutes (or until the engine starts smoking, dont worry about the smoke its just being broken in) and dont allow the needle to fall below Redline.....

    -after you have completed all the above steps you can
    enjoy the V-tec.......monster torque, dont mind everyone on here....it's jealousy
     
  13. E-dub

    E-dub New Member

    Joined:
    May 17, 2007
    Messages:
    318
    Likes Received:
    0
    No jealousy here for interheaters/wrong length headers/hideous front end.
     

Share This Page