.NET "security" problem

Discussion in 'OT Technology' started by VBGOD, Jul 27, 2003.

  1. VBGOD

    VBGOD Guest

    Problem creating or editing ASP .NET apps.

    Has anybody ever seen this before?

    [​IMG]

    Server cannot access application directory 'c:\cookies\webapp\'. The directory does not exist or is not accessible because of security settings.

    [​IMG]
    Each of these users has FULL rights, and I am the Administrator.
     
  2. mf101

    mf101 Guest

    Nope, cause I installed my shit properly...
     
  3. VBGOD

    VBGOD Guest

    Don't respond if you don't have any solutions.

    Thank you. :)
     
  4. mf101

    mf101 Guest

    Reinstall... seriously.
     
  5. turbo91

    turbo91 New Member

    Joined:
    Jun 14, 2002
    Messages:
    2,521
    Likes Received:
    0
    Location:
    San Diego, CA
    They are password protected, and you can't "login" as them. They are not associated with user accounts. The debugger is a special priviledge level, and essentially owns administrator, but again--they are not / can not be user accounts associated with these accounts.
     
  6. VBGOD

    VBGOD Guest

    :ugh: :ugh: :ugh: :ugh: :ugh: :ugh: :ugh: :ugh:

    What would be different this time around?

    Would you like to install

    [Yes]

    Installing.....

    Have a nice day!

    :dunno:

    OH, and I did re-install it. It didn't do anything. I'm looking for a real fix here. :(
     
  7. Ebtek

    Ebtek Afraid of 138

    Joined:
    Mar 19, 2000
    Messages:
    152,857
    Likes Received:
    1,065
    what are the "share" permissions?
     
  8. mf101

    mf101 Guest

    You'll have other problems beyond this one... something is fucked.
     
  9. turbo91

    turbo91 New Member

    Joined:
    Jun 14, 2002
    Messages:
    2,521
    Likes Received:
    0
    Location:
    San Diego, CA
    Here's some info on .NET impersonation:

    MSDN
     
  10. SLED

    SLED build an idiot proof device and someone else will

    Joined:
    Sep 20, 2001
    Messages:
    28,118
    Likes Received:
    0
    Location:
    AZ, like a bauce!
    ok, the ASPNet user needs to have read ( and probably execute ) rights to that directory. Doesn't matter what admin's have because the .NET web stuff runs under ASPNet
     
  11. carlin

    carlin Guest

    just wondering ... is the second item "ASP.NET Machine account *" ... u're asp.net process runner account?

    another thing...to make sure its the security problem ...not a generic issue...i suggest adding "everyone" and see if that solves the problem... otherwise there may be other problems...
     
  12. VBGOD

    VBGOD Guest

    I added a shit load of users to the folder, changed the IIS setting to "execute", and it worked.

    THEN, the database connection wasn't working anymore, but the solution to that problem "NT AUTHORITY\NETWORK SERVICE" is to add the role "IIS_WPG" to the SQL Server.

    God damn! So much trouble and so many differences in Windows 2003. I also had to add and register the CDONTS dll for simple emailing. I'll have to use the .NET way eventually though. Also, you're no longer allowed to use ".." within ASP pages. It wants the full path to each document.

    Man o man. Everything is fine, but it feels as if I was jumping though hoops to get all of this to work.
     

Share This Page