My HU is acting up...can it be fixed?

Discussion in 'OT Technology' started by TQ, May 6, 2004.

  1. TQ

    TQ OT Supporter

    Joined:
    Sep 20, 2002
    Messages:
    35,418
    Likes Received:
    9
    Location:
    Kansas City, MO
    I have a Alpine CDA-7875
    http://www.carsound.com/reviews/hd_units/cda-7875.html

    The other day, my brother ejected a disc and after it spit the disc out, it froze. I couldn't turn it off or anything, it just read "ERROR" on the face.

    I got home and unplugged it to reset it and it did the same thing.

    Finally I closed the face gently with my hand (its motorized) and from there I could turn it on and off.

    So i turned it back on and now it just sits there turning it self on and off, powercyling itself over and over again :rant2:



    Is this a common problem? Where can I get it fixed? :hs:
     
  2. Maud'dib

    Maud'dib It's always summer on the inside...

    Joined:
    May 21, 2002
    Messages:
    6,597
    Likes Received:
    0
    Location:
    UC Los Angeles Hometown: San Diego,
    I had a Kenwood KDC-9017 that did this once :dunno:. I looked around inside, was told that it'd cost me 40 bucks to have Kenwood even look at it for me, and then scrapped it and decided I didn't wanna bother with it.

    I ended up believing that the ribbon cable which attaches the faceplate to the HU body was corroded or broken, and never bothered to try changing it.

    That's all I can tell you, though.
     
  3. Luni420

    Luni420 Boost Addict

    Joined:
    Nov 23, 2002
    Messages:
    118
    Likes Received:
    0
    Try getting to the unit, theres usually a reset button yuo hit with a pin or paperclip.

    If not pull it out, with the ignition wire off, pull the yellow wire off and let it sit for a few minutes.
     
  4. TQ

    TQ OT Supporter

    Joined:
    Sep 20, 2002
    Messages:
    35,418
    Likes Received:
    9
    Location:
    Kansas City, MO

    If you read my post, I already said I tried to reset it :o


    I plugged it back in today just for shits and the damn thing wouldn't even power up. If you press the ON button it beeps once and the lights flash :wtc:
     

Share This Page