My computer wont sleep on its own anymore

Discussion in 'OT Technology' started by Pineapple Devil, Dec 20, 2006.

  1. Pineapple Devil

    Pineapple Devil beat it!

    Joined:
    Oct 8, 2001
    Messages:
    53,752
    Likes Received:
    8
    i've got it set to put the computer to sleep after an hour of inactivity and to put the hd asleep when possible. it stopped doing it 2 days ago.

    any ideas?
     
  2. ih8mice

    ih8mice New Member

    Joined:
    Dec 14, 2006
    Messages:
    417
    Likes Received:
    0
    Location:
    MI
    is there an app running in the background preventing it from sleeping?
     
  3. Pineapple Devil

    Pineapple Devil beat it!

    Joined:
    Oct 8, 2001
    Messages:
    53,752
    Likes Received:
    8
    not that i'm aware of. the only things i leave running are mail, ical, and safari. i just restarted after the lastest security update and i've got to go to work at 11 so i'll find out then if there was something running
     
  4. tenplanescrashing

    tenplanescrashing Active Member

    Joined:
    Jan 9, 2005
    Messages:
    9,287
    Likes Received:
    0
    i'd close mail and see if that gets rid of your problem. my laptop won't sleep sometimes when I have my mail open and it's usually because it is either checking for mail in the background or attempting to send when it sees something in the outbox.
     
  5. Pineapple Devil

    Pineapple Devil beat it!

    Joined:
    Oct 8, 2001
    Messages:
    53,752
    Likes Received:
    8
    ok so its not mail. i closed it and set my computer to sleep after 30 minute of inactivity. it was still awake this morning
     
  6. xenon supra

    xenon supra OT Supporter

    Joined:
    Feb 3, 2005
    Messages:
    33,675
    Likes Received:
    0
    Location:
    San Diego, CA
    have you restarted your computer since 2 days ago?
     
  7. Pineapple Devil

    Pineapple Devil beat it!

    Joined:
    Oct 8, 2001
    Messages:
    53,752
    Likes Received:
    8
  8. manchild

    manchild OT Supporter

    Joined:
    Mar 16, 2005
    Messages:
    11,507
    Likes Received:
    1
    Location:
    Chicago
    Try setting it to like 30 seconds so you don't have to wait an hour every time you want to update us.

    Try shutting down and letting it sit for a bit, then turning it on and seeing if anything happens.
     
  9. xenon supra

    xenon supra OT Supporter

    Joined:
    Feb 3, 2005
    Messages:
    33,675
    Likes Received:
    0
    Location:
    San Diego, CA
    repair permissions. :bowdown:
     
  10. slfmade

    slfmade New Member

    Joined:
    Jul 16, 2002
    Messages:
    3,954
    Likes Received:
    0
    Location:
    Terrapin Station
    .
     
  11. tenplanescrashing

    tenplanescrashing Active Member

    Joined:
    Jan 9, 2005
    Messages:
    9,287
    Likes Received:
    0
    the reason I won't sleep is because there is a program or process that needs to access resources and the computer won't sleep in that case. Quit all apps and then take a look at your Activity Monitor and see what is taking up the most CPU %.

    I also think permissions should be repaired too but i'd try the activity thing first.
     
  12. Pineapple Devil

    Pineapple Devil beat it!

    Joined:
    Oct 8, 2001
    Messages:
    53,752
    Likes Received:
    8
    ok i rebooted and looked at activity monitor to see what is taking up the most cpu and it was activity monitor and the pmtool that goes with it. nothing out of the ordinary had any cpu usage.

    i reset permissions to both the hd and the partition for "macintosh hd".

    i set it to sleep after 1 minute after all of that and it still didnt go to sleep on its own

    i'm going to shut it down for the night and see if anything helps it for the morning
     
  13. Pineapple Devil

    Pineapple Devil beat it!

    Joined:
    Oct 8, 2001
    Messages:
    53,752
    Likes Received:
    8
    i left it off last night and booted it this morning with nothing attached to it (monitor, usb cables, speakers) and let it sit for 1 minute to see if it would sleep. it did.

    i hooked everything back up to it and opened the programs i normally leave open (mail, safari, ical) and let it sit for 1 minute to see if it would sleep. it did.

    seems to be fixed now. i'm going to wait 1 hour today to see if it'll still sleep but it should

    thanks for the help
     

Share This Page