Mechanics/Toyota Truck Crew: EFI fuse keeps blowing

Discussion in 'OT Driven' started by Rip The Jacker, Feb 9, 2010.

  1. Rip The Jacker

    Rip The Jacker New Member

    Joined:
    Jul 24, 2002
    Messages:
    53,993
    Likes Received:
    0
    I think something's shorting because of the snow, but I cant figure out what. Any ideas where to start looking? I want to minimize my time in the snow when I get back out there.

    Only thing I can think of is a sensor connector somewhere around the transfer case/drive shaft is hanging pretty low.
     
  2. Kyoso

    Kyoso New Member

    Joined:
    Oct 27, 2003
    Messages:
    33,301
    Likes Received:
    0
    Location:
    AZ
    Sounds like you have an O2 sensor problem, like a short or something. Is the wiring by it fucked up at all?
     
  3. -Bill

    -Bill Member OT Supporter

    Joined:
    Sep 28, 2006
    Messages:
    1,470
    Likes Received:
    0
    Tundra ? Older Tundra's would blow the fuse when the fuel pump was bad.
     
  4. Browning

    Browning Active Member

    Joined:
    Feb 14, 2005
    Messages:
    89,465
    Likes Received:
    10
    start at the tank. Can you hear the pump kick on? If no, replace pump. If yes, start checking the wiring from the pump forward for cracks, cut, etc
     
  5. -Bill

    -Bill Member OT Supporter

    Joined:
    Sep 28, 2006
    Messages:
    1,470
    Likes Received:
    0
    Just checked, that was for 2000 - 2002 Tundra.
     
  6. Rip The Jacker

    Rip The Jacker New Member

    Joined:
    Jul 24, 2002
    Messages:
    53,993
    Likes Received:
    0
    by the o2 sensor? theres a low hanging cable by the t-case, connectors corroded on the inside, dont know if its for the o2 sensor though. didnt have time to look :hs:
     
  7. threesixty

    threesixty OT Supporter

    Joined:
    Jul 2, 2005
    Messages:
    14,297
    Likes Received:
    0
    Location:
    Venice, CA
    Probably bad brakes.
     
  8. Rip The Jacker

    Rip The Jacker New Member

    Joined:
    Jul 24, 2002
    Messages:
    53,993
    Likes Received:
    0
    the truck runs with a new fuse, so i assume the pump is fine :dunno:
     
  9. Kyoso

    Kyoso New Member

    Joined:
    Oct 27, 2003
    Messages:
    33,301
    Likes Received:
    0
    Location:
    AZ
    If you're having grounding issues of any kind on your O2 sensor it will pop that fuse. What year and model is your truck?
     
  10. Rip The Jacker

    Rip The Jacker New Member

    Joined:
    Jul 24, 2002
    Messages:
    53,993
    Likes Received:
    0
    1992 22re manual transmission.
     
  11. Kyoso

    Kyoso New Member

    Joined:
    Oct 27, 2003
    Messages:
    33,301
    Likes Received:
    0
    Location:
    AZ
    OK, so check the wiring from the O2 sensor up. You might find that the wiring is melted/fucked up from your exhaust. Other possibilities are a little harder to check from that point. Does it pop the fuses intermittantly or right away?
     
  12. Browning

    Browning Active Member

    Joined:
    Feb 14, 2005
    Messages:
    89,465
    Likes Received:
    10
  13. Rip The Jacker

    Rip The Jacker New Member

    Joined:
    Jul 24, 2002
    Messages:
    53,993
    Likes Received:
    0

    it runs for a little bit and then blows.
     
  14. Rip The Jacker

    Rip The Jacker New Member

    Joined:
    Jul 24, 2002
    Messages:
    53,993
    Likes Received:
    0
  15. Kyoso

    Kyoso New Member

    Joined:
    Oct 27, 2003
    Messages:
    33,301
    Likes Received:
    0
    Location:
    AZ
    Take some extra wire and some electrical tape with you. :bigthumb: Good luck mang.
     
  16. Rip The Jacker

    Rip The Jacker New Member

    Joined:
    Jul 24, 2002
    Messages:
    53,993
    Likes Received:
    0
    I'm just dreading being out in the snow and dark trying to track this thing down :hs:
     
  17. Rip The Jacker

    Rip The Jacker New Member

    Joined:
    Jul 24, 2002
    Messages:
    53,993
    Likes Received:
    0
    yup, o2 sensor. i put the wiring in incorrectly during my engine swap, drive shaft rubbed a hole in it.

    thanks guys.
     
  18. spooled2.2

    spooled2.2 OT Supporter

    Joined:
    Mar 1, 2002
    Messages:
    41,446
    Likes Received:
    36
    Location:
    endless summer
    Better recall EVERY SINGLE ONE OF THEM. CONTACT THE NHTSA NOW. DO NOT DRIVE YOUR VEHICLE.
     
  19. hypermonkey

    hypermonkey Tastes just like raisins.

    Joined:
    Dec 3, 2000
    Messages:
    36,763
    Likes Received:
    0
    Location:
    Bakalakadaka St.
    You bought a cheaply made foreign "truck."
     
  20. Rip The Jacker

    Rip The Jacker New Member

    Joined:
    Jul 24, 2002
    Messages:
    53,993
    Likes Received:
    0
    and i love it.
     
  21. Kyoso

    Kyoso New Member

    Joined:
    Oct 27, 2003
    Messages:
    33,301
    Likes Received:
    0
    Location:
    AZ
  22. borazhasleftthebuilding

    borazhasleftthebuilding Lets Party OT Supporter

    Joined:
    Feb 11, 2005
    Messages:
    98,360
    Likes Received:
    234
    Location:
    in da forest
    is it in the exhaust? :hsugh:
     
  23. Kyoso

    Kyoso New Member

    Joined:
    Oct 27, 2003
    Messages:
    33,301
    Likes Received:
    0
    Location:
    AZ
    Awesome post, bernie.:hsugh:
     
  24. borazhasleftthebuilding

    borazhasleftthebuilding Lets Party OT Supporter

    Joined:
    Feb 11, 2005
    Messages:
    98,360
    Likes Received:
    234
    Location:
    in da forest
    sadly too late :wtc:
     
  25. Rip The Jacker

    Rip The Jacker New Member

    Joined:
    Jul 24, 2002
    Messages:
    53,993
    Likes Received:
    0
    I didn't get a look at it before I got to work and made this thread.

    Theres hardly anything left of the wire. Check engine light keeps popping on and off :noes:
     

Share This Page