Linux gurus, help! v.FC3

Discussion in 'OT Technology' started by Mourning Wood, May 16, 2006.

  1. Mourning Wood

    Mourning Wood New Member

    Joined:
    Jul 13, 2004
    Messages:
    2,755
    Likes Received:
    0
    My install of Fedora Core 3 has problems booting up. It worked fine for the longest time, but now every time I start it it stops before the GUI loads. Black screen with the hour glass icon. Then I have to press ctrl+alt+f1 which gives me this prompt:
    Code:
    Fedora Core release 3 (Heidelberg)
    Kernel 2.6.9-1.667 on an i686
    
    localhost login:
    So then I enter my root username and password and I get to this:
    Code:
    [[email protected] ~]#
    I enter "startx" (normally I wouldn't have to do all this, it would just load to the desktop) and get this.
    Code:
    Fatal server error:
    Server is already active for display 0
              If this server is no longer running, remove /tmp/.X0-lock
              and start again.
    
    blah blah blah
    
    Xlib: connection to ":0.0" refused by server
    Xlib: Invalid MIT-MAGIC-COOKIE-1 key
    giving up
    Xlib: unable to connect to X server
    Xlib: No such process (errno 3): Server error.
    [[email protected] ~]#
    So then I "rm /tmp/.X0-lock" and "startx" and it loads fine. This is just a pain in the ass to do every time I start the damn thing.

    Is there any way to fix this without a reformat? :x:
     
  2. rsxm5

    rsxm5 OT Supporter

    Joined:
    Oct 13, 2002
    Messages:
    2,961
    Likes Received:
    0
    Location:
    San Diego, CA
    Does it only do it when you are logged in as root? Try it with another user.
     
  3. Mourning Wood

    Mourning Wood New Member

    Joined:
    Jul 13, 2004
    Messages:
    2,755
    Likes Received:
    0
    It does it before I log in, while it's booting up. Normally I didn't have to login at a command prompt like above, I just have to do that now to delete that "lock" file so I could start x.
     
  4. Mourning Wood

    Mourning Wood New Member

    Joined:
    Jul 13, 2004
    Messages:
    2,755
    Likes Received:
    0
    So yeah, it's the same thing whether I use root or another user :sad2:
     
  5. ShapeShifterz

    ShapeShifterz Longtime Lurker

    Joined:
    Mar 15, 2000
    Messages:
    183
    Likes Received:
    0
    Location:
    Bay Area, CA
    Are you exiting your window manager gracefully? If so, is that file still around after you do so?
     
  6. Mourning Wood

    Mourning Wood New Member

    Joined:
    Jul 13, 2004
    Messages:
    2,755
    Likes Received:
    0
    Well, here's what happens.

    I click (what's equivalent to) start, then "logout."

    Click "Logout".

    To avoid typing this all out I'm omitting what appears to be irrelevant to the problem.
    Code:
    .
    X Error: BadWindow (invalid Window parameter) 3
    .
    .
    .
    startkde: Shutting down...
    warning: leaving MCOP Dispatcher and still 12 object references alive.
    .
    .
    .
    warning: leaving MCOP Dispatcher and still 113 object references alive.
    klauncher: Exiting on signal 1
    startkde: Running shutdown scrips...
    startkde: Done.
    
    waiting for X server to shut down
    
    [[email protected] ~]#
    Then I hit the computer's front power button and it shuts off.

    :wtc:
     
  7. rsxm5

    rsxm5 OT Supporter

    Joined:
    Oct 13, 2002
    Messages:
    2,961
    Likes Received:
    0
    Location:
    San Diego, CA
    Don't hit the front power button. Try typing "halt" as that will give a "safe" shutdown.
     
  8. Mourning Wood

    Mourning Wood New Member

    Joined:
    Jul 13, 2004
    Messages:
    2,755
    Likes Received:
    0
    Same result. :sad2:
     
  9. CyberBullets

    CyberBullets I reach to the sky, and call out your name. If I c

    Joined:
    Nov 13, 2001
    Messages:
    11,865
    Likes Received:
    0
    Location:
    BC, Canada/Stockholm, Sweden
    why are you logging in as root. that is my 1st question.
     
  10. Mourning Wood

    Mourning Wood New Member

    Joined:
    Jul 13, 2004
    Messages:
    2,755
    Likes Received:
    0
    It does it even if I log in as another user. I was trying different options.
     
  11. Peyomp

    Peyomp New Member

    Joined:
    Jan 11, 2002
    Messages:
    14,017
    Likes Received:
    0
    I've long suspected that X on Linux is non-deterministsic. Seriously. Its buggy as shit. I don't remember what the relevant log is, but you should look up which one it is, less it, then google the errors you get.

    Sometimes I hate X. Aqua ftw.
     
  12. rsxm5

    rsxm5 OT Supporter

    Joined:
    Oct 13, 2002
    Messages:
    2,961
    Likes Received:
    0
    Location:
    San Diego, CA
    Do you have any window managers installed? Have you tried using Gnome?
     
  13. Harry Caray

    Harry Caray Fine purveyor of x.264, h.264 & TS HD-Video !!! HD

    Joined:
    Apr 19, 2001
    Messages:
    17,176
    Likes Received:
    5
    Location:
    MyCrews:4x4,SoCal,Tesla,EV's
    STFU.... it's just because you don't know it :rolleyes:

    It's probably one of the most solid OS's around... and the *Kernel*... FreeBSD and others that all based on *POSIX*.... are all soild...

    And your Aqua.... was founded in X just so you know :mamoru: They just took it further...

    As for this guy's problems, try to boot the box with the GRUB menu and INIT X manually first....

    if you want to modifiy the X stuff, just write back and I'll show you how to go into the settings/config system and change it back to stock 640x480 and then restart with the CTRL-ALT-BACKSPACE...

    then CTRL-ALT-F7



    if your GFX card has changed
     
  14. Mourning Wood

    Mourning Wood New Member

    Joined:
    Jul 13, 2004
    Messages:
    2,755
    Likes Received:
    0
    No hardware has changed. I'm using the KDE window manager. I'll try Gnome and see if that helps.
     
  15. Penguin Man

    Penguin Man Protect Your Digital Liberties

    Joined:
    Apr 27, 2002
    Messages:
    21,696
    Likes Received:
    0
    Location:
    Edmonton, AB
    Actually, you probably don't know what you're talking about. I'm as big a Linux fan as you'll find around here, but Peyomp is right: X has serious issues. It's a bitch to get working properly a lot of the time. Xorg is better than XF86 used to be, but it's still not great.

    That said, I can't fucking stand using Aqua.
     
  16. Mourning Wood

    Mourning Wood New Member

    Joined:
    Jul 13, 2004
    Messages:
    2,755
    Likes Received:
    0
    I can't get it to login with a different window manager :wtc:

    I might just say fuck it and reformat.
     
  17. Penguin Man

    Penguin Man Protect Your Digital Liberties

    Joined:
    Apr 27, 2002
    Messages:
    21,696
    Likes Received:
    0
    Location:
    Edmonton, AB
    Let it crash, then immediately check /var/log/Xorg.0.log to see what happened. This should give you some clues.
     
  18. Harry Caray

    Harry Caray Fine purveyor of x.264, h.264 & TS HD-Video !!! HD

    Joined:
    Apr 19, 2001
    Messages:
    17,176
    Likes Received:
    5
    Location:
    MyCrews:4x4,SoCal,Tesla,EV's
    FAN ??? or guru??? or *EXPERT*....

    I do nothing but pretty much admin *unix and Linux (FC & Suse) Beowulfs/SCYLD clusters all day long.. so I'm considered myself an *EXPERT* as well as by the people who pay my very nice $$$'s as well... (The LPI cert helps as well ;) )

    anywho... yea... whoever says Aqua sucks... just lost all streetcred with me right there.... we not talking about the actually GUI (if you're not smart enough to change the look of it :mamoru: ) then don't talk about the architecture or where it's true roots are from...

    /thread for me
     
  19. Peyomp

    Peyomp New Member

    Joined:
    Jan 11, 2002
    Messages:
    14,017
    Likes Received:
    0
    d00d 33f j00 d0nt gn0 X 0|\| l3n00x 3z uns+4b3 j00 5ux0rs :rofl: :rofl: :rofl:
     
  20. Peyomp

    Peyomp New Member

    Joined:
    Jan 11, 2002
    Messages:
    14,017
    Likes Received:
    0
    d00d 3y3 gn0z th1ngs!!!!!!

    :rofl: :rofl: :rofl:

    We have a new village idiot :)
     
  21. Mourning Wood

    Mourning Wood New Member

    Joined:
    Jul 13, 2004
    Messages:
    2,755
    Likes Received:
    0
    Too late, I've already started installing Gentoo :hsd:
     
  22. Peyomp

    Peyomp New Member

    Joined:
    Jan 11, 2002
    Messages:
    14,017
    Likes Received:
    0
    Good for you. You shouldn't have to do anything to get your GUI to work. It should just work. its 2006 for fuck's sakes, and you have better things to do. Also, FC3 is a piece of crap.
     

Share This Page