Laptop help

Discussion in 'OT Technology' started by SoundofSilence, Feb 4, 2008.

  1. SoundofSilence

    SoundofSilence New Member

    Joined:
    Jan 11, 2008
    Messages:
    4
    Likes Received:
    0
    I have a G320 laptop and it's not turning on anymore. When I press the power button, the light comes on for a few seconds and goes straight back off again, and when I plug it in, the light to show it's plugged in comes on, the battery charging light comes on, but when I press the power button, they all go off.

    I have no idea what's wrong with it tbh, was working fine before.

    I can hear a whistling type buzzing sound comming from it when it's either plugged in or I'm pressing the power button, but it's just not powering up.

    Anyone have any ideas of how to fix it? Would be much appreciated. :)
     
  2. deusexaethera

    deusexaethera OT Supporter

    Joined:
    Jan 27, 2005
    Messages:
    19,712
    Likes Received:
    0
    This is all hypothetical, but I'm guessing the laptop found out you let its warranty expire, so it concluded you must not love it anymore, and since you're the only man who ever touched it that way, it couldn't stand the pain of loss and it killed itself.

    You bastard.
     
  3. cmsurfer

    cmsurfer ºllllllº

    Joined:
    Jun 6, 2003
    Messages:
    5,079
    Likes Received:
    0
    Location:
    NJ
    This is definitely a longshot, but take out one the RAM sticks and test to see what happens. I had a laptop given to me that would only turn on when the bottom RAM slot was empty...
     
  4. Sicarius123

    Sicarius123 Without ME, it's just AWESO

    Joined:
    Jan 10, 2008
    Messages:
    246
    Likes Received:
    0
    Location:
    Australia
    Tried taking out the battery and re-seating it? Had a laptop at work that the baggage handlers on a flight had half crushed and it had this same problem, re-seated the battery and it worked again (while still looking a bit unfortunate and bent).
     
  5. SoundofSilence

    SoundofSilence New Member

    Joined:
    Jan 11, 2008
    Messages:
    4
    Likes Received:
    0
    I've taken the whole thing apart, everything's disconnected including the screen, keyboard, mouse etc, hard drive and ram sticks taken out aswell, still doing the same thing. Tried it with different things connected/disconnected, no luck. :(

    Well, when I first got the problem, I took the battery out and put it back in, and it came on, then after I shut it down later on (I didn't think it would happen again) it's not turned on since. Fiddled round with the battery etc. just not powering. :(
     

Share This Page