its broke and i need some help

Discussion in 'OT Driven' started by High Voltage, Aug 11, 2007.

  1. High Voltage

    High Voltage Guest

    i got a 95 yamaha razz. basically its a barnyard find, grandpa passed away and i have slowly been cleaning his place out. it hasn't ran in about 5 years. well i cleaned the carburator up, new battery and spark plug. i got it to start today and let it run for about 15 minutes in the garage. well when i turned it off the fuel pump didnt shut off, it flooded to carburator and was spilling gas out the overflow. (had 2 gallons of gas on my garage floor to cleanup) this fuel pump IS NOT electric. its vaccum operated. any why its doing this? i pulled it apart and soaked it in carb cleaner for a couple of hours and reassmebled it. havent put it back in yet to see what happens. any input would be helpful. Thanks :)
     
  2. Vermincelli

    Vermincelli Banned

    Joined:
    Oct 11, 2004
    Messages:
    57,873
    Likes Received:
    0
    Location:
    GET OFF MY LAWN!
    stuck valve/diaphragm not releasing the vacuum pressure would be first guess when it comes to mechanical fuel pumps
     
  3. High Voltage

    High Voltage Guest


    so i reinstalled it and it works great :eek3: guess it just need to soak in some carb cleaner all torn apart for awhile

    now i just need to figure out where to mount a cup holder :o
     
  4. Vermincelli

    Vermincelli Banned

    Joined:
    Oct 11, 2004
    Messages:
    57,873
    Likes Received:
    0
    Location:
    GET OFF MY LAWN!
    I'm mounting my cupholder on the fairing :big grin:

    I just need to find a sturdy one that will hold a 40oz slurpee cup.

    Edit:
    found the spot to mount it.
    [​IMG]
     
    Last edited: Aug 12, 2007

Share This Page