Is it possible to fix it? V. RAZR V3 (junk)

Discussion in 'OT Technology' started by GT40, Jan 2, 2007.

  1. GT40

    GT40 lol

    Joined:
    Jun 2, 2001
    Messages:
    12,184
    Likes Received:
    0
    Ok.

    backstory: I had a black razr I got a while back. I dropped it in the pool earlier last summer and it didn't work (obviously). I used my old Nokia since then. Well recently, my GF's step mom stopped using her razr she got christmas 05. So she gave it to me and I'm using it.

    Well I put the battery from new razr into my old pool dropped one. And it worked fine for a little bit. I texted my GF and turned on the camera but didn't take any pictures. Well I accidently hit the button to go to sound recordings. And since then it's messed up. When the buttons work they go straight to the sound recording menu. Only the hang up button works like normal. :o I got the pictures and ringtones I put on there using p2kman. I was wondering if I reflashed it, is it possible that it'd work right again? I was teased for a bit there when it worked fine. And if I should try that, does anyone know where I can get motorola pst multiflash whatever it's called to reflash it?

    The only reason I'd want to fix it really would be to get my black razr back instead of the silver one. The silver one has dirt and shit on teh screen that won't wipe off and the camera doesn't work right. It looks like it's stuck in low resolution all the time. Basically looks like shit. Is that fixable? and is the dirt cleanable?



    Cliffs:
    -black razr dropped in pool
    -using GF's stepmom's old silver razr
    -battery from silver razr + sim card into old pool soaked black razr = worked
    -stopped working after going into menu
    -got pictures/ringtones off it
    -is it fixable?

    -if not, is it possible to clean the silver razr's screen? (dirt that doesn't wipe off, must be underneath) and can I get the camera to work right?
     
  2. GT40

    GT40 lol

    Joined:
    Jun 2, 2001
    Messages:
    12,184
    Likes Received:
    0
    Update: after downloading the pictures off the new phone, it looks like the camera worked fine until a certain point. there were pictures from january and february that look like normal. but then there is a big gap off time where there are no photos and since then they are all crappy quality but still same resolution...
     
  3. badguy106

    badguy106 Location:Tn

    Joined:
    Oct 20, 2004
    Messages:
    809
    Likes Received:
    0
    I cleaned mine. Took a razor blade and gently lifted up the screen cover, blew it out and replaced. No biggie. It just has adhesive around the edges of the screen cover.
     

Share This Page