is it my subs, amp or both that suck?

Discussion in 'OT Technology' started by Mikeveli, Apr 14, 2003.

  1. Mikeveli

    Mikeveli The Don

    Joined:
    May 7, 2001
    Messages:
    519
    Likes Received:
    0
    Location:
    Chicago, IL
    i have a kenwood kac-728s (600W 2CH) powering 2 12" Polk DB's (dynamic balance (discountinued))...the bass is clear and all but the bass isnt loud enough...for example my friend has just 1 12" L7 with a bass cube and a 500W amp powering it, and his shit pounds twice as hard as mine...if i get a new sub(s) or amp or both, which one would be better...
     
  2. twistid

    twistid Banged By Super Models Moderator

    Joined:
    Jul 15, 2001
    Messages:
    40,727
    Likes Received:
    81
    Location:
    The Kansass/Oklahomo Border
    i'd get a different amp for the subs, and use that kenwood for your highs/mids. that amp is only 100 X 2 WRMS.
     
  3. Mikeveli

    Mikeveli The Don

    Joined:
    May 7, 2001
    Messages:
    519
    Likes Received:
    0
    Location:
    Chicago, IL
    i actually already have a kenwood kac-848 for my insides...also sometimes during a song...the bass from the subs will just not be there when it should, the bass would dissapear then gradually come back on (while the song is still playing throught the inside speakers)...this happens when i turn the volume up pretty loud..when volume is low/medium level it works fine...
     
  4. Mikeveli

    Mikeveli The Don

    Joined:
    May 7, 2001
    Messages:
    519
    Likes Received:
    0
    Location:
    Chicago, IL
    which amp would u recommend...
     
  5. NisAznMonk

    NisAznMonk New Member

    Joined:
    Dec 1, 2001
    Messages:
    1,476
    Likes Received:
    0
    Location:
    Houston, Tx
    I'd say rebuild your subwoofer box before getting another amp. Get one built to the specs of your subs, and it should work fine. I had the same problem, and it was because my ports were tuned wrong.
     
  6. Audiophile

    Audiophile boom boom

    Joined:
    Sep 22, 2002
    Messages:
    2,023
    Likes Received:
    0
    Location:
    Ephrata, PA
    i dont see how a 12" L7 can pound that hard. those woofers require A LOT of power. i had a 12" L5 being pushed with a jl 500/1 which pushes more than 500 watts and it was pussy. let alone an L7. ive heard L7's sound loud, it was givin over 1000 watts though.
     
  7. 04

    04 Guest

    My friend's 12" L7 is loud with only 250 watts.
     
  8. Audiophile

    Audiophile boom boom

    Joined:
    Sep 22, 2002
    Messages:
    2,023
    Likes Received:
    0
    Location:
    Ephrata, PA


    i guess it was my enclosure, but my 12" L5 sure didn't. my single 12" w3v1 in a prowedge owned it both in SQ and SPL (what SPL it did have)
     

Share This Page