Internet Speeds Problem v.possible bad router

Discussion in 'OT Technology' started by Zak8022, Nov 27, 2007.

  1. Zak8022

    Zak8022 New Member

    Joined:
    Apr 16, 2004
    Messages:
    4,012
    Likes Received:
    0
    Location:
    Maryland
    So, i had comcast out today, cuz my internet speeds have been pretty shitty lately. I'm supposed to get 6MB down, and 300-somethin up.

    After a new modem, i get 16MB down, and 1.5MB up... when my laptop is plugged directly into the modem.

    Here's the weird shit.... basically any time things are going thru my Netgear router, my speeds are limited to 4MB down (i still get the normal 1.5MB up tho). The router is a Netgear FVS318, running firmware v2.4.

    What could be causing my router to limit my speeds to 4MB download? I have been around the router firmware extensively, and it has no controls that i am aware of to limit speeds. Is is possible that it is malfunctioning... but its ONLY symptom being slow download? Is this a 10/100 vs gigabit ethernet issue? I don't think it is, but my math might be off.

    Any help is appreciated it.
     
  2. Sexual Vanilla

    Sexual Vanilla New Member

    Joined:
    May 23, 2005
    Messages:
    6,305
    Likes Received:
    0
    Location:
    South Carolina
    Sounds similar to my problem I had in my other recent thread. Download Dr. TCP (http://www.dslreports.com/drtcp), and run it on the interface you are using (wireless or wired). Make sure your MTU is 1500 and your TCP Receiving window is at least 100000. Save changes and reboot and test again.
     

Share This Page