How to: Remote Acces to my Desktop via laptop

Discussion in 'OT Technology' started by mad doc, Dec 12, 2005.

  1. mad doc

    mad doc New Member

    Joined:
    Oct 24, 2005
    Messages:
    28
    Likes Received:
    0
    I'm trying to understand how to gain remote access to my desktop via my laptop when I am, say, at work or at a class.

    As it is right now, I can access my desktop from my laptop when they are using the same internet connection/router. When I leave here and move over to the school internet, I cannot access the computer. I understand the whole 198.xxx.xxx.x is for the home network and computers on that network.

    I guess my question is, how can I gain access to my desktop when I am using another internet connection in a different area, etc? How do I obtain the correct IP I need to use (when on the home network I just use 198.xxx.xx.x)?There's been many times I've been in class and needed something off my desktop and been pissed thatI couldn't get to it.

    My home network uses a Linksys WRT54G, and I'm using the Microsoft given Remote Desktop Access client to access my home PC (that has WinXP pro).
     
  2. Penguin Man

    Penguin Man Protect Your Digital Liberties

    Joined:
    Apr 27, 2002
    Messages:
    21,696
    Likes Received:
    0
    Location:
    Edmonton, AB
    You need to setup port forwarding on the router. Figure out what port remote desktop uses (900 something I think) and setup the router to forward that port to your desktop. Then find out your external IP (go to whatismyip.com) and connect to that from outside. The router will get the connection from outside and forward it to your desktop.
     
  3. mdaniel

    mdaniel S is for Shiksa

    Joined:
    May 6, 2000
    Messages:
    52,498
    Likes Received:
    310
    Location:
    Northwest Mejicooooooo
    Give your desktop a static IP address. If your router is 192.168.1.1 and the DHCP pool is 192.168.1.100 through 192.168.1.150, make your desktop 192.168.1.x as long as the x isn't between 100 and 150. Then configure the router to forward port 3389 for 192.168.1.x.

    For the IP address, whatismyip.com is good but if you're on a PPPoE connection, it could change by the time you get to class and try to connect. Get a dynamic DNS provider that gives your computer a DNS name. You'll run a program on your computer that keeps your dynamic DNS provider informed of your current IP address. My Netgear can do this w/o extra software. Not sure about Linksys. Either way, you point your remote desktop to something like mycomputer.dyndns.org instead of always having to write down and IP address and hope it doesn't change.
     
  4. cmsurfer

    cmsurfer ºllllllº

    Joined:
    Jun 6, 2003
    Messages:
    5,079
    Likes Received:
    0
    Location:
    NJ
    Like said above, you need to forward port 3389 on your router to the internal IP of the machine you want to connect to. You then connect using your external IP.

    If you go to www.dslwebserver.com and click the step by step link on the left, you'll see step by step directions for setting it up.
     
  5. spyder2581

    spyder2581 Active Member

    Joined:
    Jun 2, 2004
    Messages:
    2,108
    Likes Received:
    0
    Location:
    Michigan
  6. EvilSS

    EvilSS New Member

    Joined:
    Jun 11, 2003
    Messages:
    5,104
    Likes Received:
    0
    Location:
    STL
  7. Penguin Man

    Penguin Man Protect Your Digital Liberties

    Joined:
    Apr 27, 2002
    Messages:
    21,696
    Likes Received:
    0
    Location:
    Edmonton, AB
    Oh yeah, I forgot that people still use PPP. No one here has used it since dial-up (our DSL providers all use good old DHCP).
     
  8. mdaniel

    mdaniel S is for Shiksa

    Joined:
    May 6, 2000
    Messages:
    52,498
    Likes Received:
    310
    Location:
    Northwest Mejicooooooo
    Yeah I wish PPPoE would die but SBC Yahoo DSL and others still use it. To me, its just one more layer to troubleshoot when someone can't get online. grrrrrr Thankfully Verizon DSL out here is DHCP but they have their own problems.
     

Share This Page