Help with tunneling Torrent traffic over SSH?

Discussion in 'OT Technology' started by TenSteel, Sep 22, 2007.

  1. TenSteel

    TenSteel Ted Cruz suicide hotline OT Supporter

    Joined:
    Nov 11, 2001
    Messages:
    13,835
    Likes Received:
    499
    Location:
    San Diego
    So I'm on Mac on OSX 10.4, using Azureus. I signed up for a shell account at sdf.lonestar.org

    I've read the tutorial on the site, but everything there is for Windows based
    computers to use a program like Putty. I'm merely firing up my terminal and attempting to do SSH from the command line.

    I'm basing my actions around this guide:
    http://whalesalad.com/2006/08/27/tunneling-bittorrent-over-ssh/

    ... but I have a slight problem. Here is the command line I'm using right now:

    Davids-iMac-G5:~ david$ ssh -p 443 [email protected] -D 7777
    [email protected]'s password:
    Last login: Fri Sep 21 17:33:50 2007 from c-71-202-214-19

    Then once I fire up my Azureus client, I see this error when I start to announce to the tracker:
    $ channel 3: open failed: connect failed: No route to host

    These are my settings in Azureus:
    "Enable proxying of tracker communications" and "I have a SOCKS proxy"
    Host: localhost
    Port: 7777

    Incoming TCP listen port: 7777
    Incoming UDP listen port: 7777

    Any unix/linux geeks out there who can help?
     
    Last edited: Sep 22, 2007
  2. SLED

    SLED build an idiot proof device and someone else will

    Joined:
    Sep 20, 2001
    Messages:
    28,118
    Likes Received:
    0
    Location:
    AZ, like a bauce!
    hmmm, once you initiate the telnet session, can you "telnet localhost 7777" and get a response? Might be something with your firewall.
     
  3. P07r0457

    P07r0457 New Member

    Joined:
    Sep 20, 2004
    Messages:
    28,491
    Likes Received:
    0
    Location:
    Southern Oregon
    no good can come from this.
     
  4. TenSteel

    TenSteel Ted Cruz suicide hotline OT Supporter

    Joined:
    Nov 11, 2001
    Messages:
    13,835
    Likes Received:
    499
    Location:
    San Diego
    ahah, now we're getting somewhere, looks like it may be an issue with my firewall:

    $ telnet localhost 7777
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused
    $


    This is after I'm connected to freeshell through SSH. I'm trying to configure my port forwarding on my D-Link router to no success.
     
  5. samm

    samm Next in Line

    Joined:
    Dec 22, 2000
    Messages:
    2,630
    Likes Received:
    0
    Location:
    San Jose, CA
    Is your firewall enabled in System Preferences -> Sharing -> Firewall tab?
     
  6. TenSteel

    TenSteel Ted Cruz suicide hotline OT Supporter

    Joined:
    Nov 11, 2001
    Messages:
    13,835
    Likes Received:
    499
    Location:
    San Diego
    it is. i turned it off, and also enabled DMZ (Demilitarized Zone) for this computer on my router, which basically takes the computer out of the router's firewall. Even with both of these firewalls off I still get the error. :rant2:
     
  7. SLED

    SLED build an idiot proof device and someone else will

    Joined:
    Sep 20, 2001
    Messages:
    28,118
    Likes Received:
    0
    Location:
    AZ, like a bauce!
    You don't need to port forward anything on your router. When you connect to the remote server, the tunnel is already connected.

    Have you tried running it from the commandline with sudo?

    i.e. sudo ssh ...

    and then entering your password?
     
  8. TenSteel

    TenSteel Ted Cruz suicide hotline OT Supporter

    Joined:
    Nov 11, 2001
    Messages:
    13,835
    Likes Received:
    499
    Location:
    San Diego
    no, but i ill give it a shot. i just looked up what that does.


    btw, i unplugged my router and it works now, so i need to figure out how to make it work with my router in use.
     
  9. samm

    samm Next in Line

    Joined:
    Dec 22, 2000
    Messages:
    2,630
    Likes Received:
    0
    Location:
    San Jose, CA
    you won't need root to bind to a non-privileged port, 7777 is not privileged. Read the ssh man page about the -D argument.
     
  10. TenSteel

    TenSteel Ted Cruz suicide hotline OT Supporter

    Joined:
    Nov 11, 2001
    Messages:
    13,835
    Likes Received:
    499
    Location:
    San Diego
    Yeah, sudo sssh doesn't make it work with the router, just tried.

    So this now sounds like it's going to be a router/IP address configuration issue now. What next?

    Alright, I did some port forwarding at my router and it appears to be working now. Looks like I won't be at a desirably connectable status (NAT isn't "OK"), but I may just have to live with that.
     
    Last edited: Sep 23, 2007

Share This Page