WEB help with celeron dude's uploader?

Discussion in 'OT Technology' started by White Stormy, May 4, 2008.

  1. White Stormy

    White Stormy Take that, subspace!

    Joined:
    Sep 17, 2002
    Messages:
    85,485
    Likes Received:
    69
    Location:
    Sparkopolis
    v6.1 installed fine.. when I try to view a user's files, though, I get an error.

    http://www.halefx.com/uploader/files/1/apttvfe.jpg
    the location of file.php is http://www.halefx.com/uploader/file.php

    I think the absolute path in the settings is correct, and all other files work. :(

    I found several people in the celerondude forums with the same problem I have.. but none of them posted a solution. several of them edited their posts later with "nevermind: fixed!" but they didn't post HOW it was fixed :wtc:
     
  2. White Stormy

    White Stormy Take that, subspace!

    Joined:
    Sep 17, 2002
    Messages:
    85,485
    Likes Received:
    69
    Location:
    Sparkopolis
    hrmm I deleted the .htaccess file inside the "files" folder and now it looks like everything works..
     
  3. Browning

    Browning Active Member

    Joined:
    Feb 14, 2005
    Messages:
    89,465
    Likes Received:
    10
    what was inside that .htaccess?
     
  4. White Stormy

    White Stormy Take that, subspace!

    Joined:
    Sep 17, 2002
    Messages:
    85,485
    Likes Received:
    69
    Location:
    Sparkopolis
    no clue :o

    I saw where a lot of people were having other problems.. not even close to mine.. but other problems.. and that was causing them.

    I figured worst case, I reupload and reinstall.

    but it worked :o
     
    Last edited: May 4, 2008
  5. crazybenf

    crazybenf Active Member

    Joined:
    Nov 14, 2001
    Messages:
    15,575
    Likes Received:
    2
    cel dude uploader hta should be:

    Code:
    # This is a comment because the line starts with the # character.
    # Disable a line by commenting it.
    
    DirectoryIndex index.php
    Options -Indexes
    
    # These might give you an error if PHP is not installed as a module.
    php_value upload_max_filesize 200M
    php_value post_max_size 200M
    php_value short_open_tag 1
    
    
    # Delete or comment out these lines if you're getting Internal Server error because your server does not have mod_rewrite.
    RewriteEngine On
    
    # For public uploader
    RewriteRule ^register/?$ account.php?action=register [L,NC]
    RewriteRule ^login/?$ account.php?action=login [L,NC]
    RewriteRule ^pupload/?$ public.php [L,NC]
    RewriteRule ^pupload/browse(/([0-9]+))?/?$ public.php?action=browse&page=$2 [L,NC]
    RewriteRule ^pupload/view/([0-9]+)/?$ public.php?action=view&upload_id=$1 [L,NC]
    RewriteRule ^pupload/manage/([0-9]+)/([0-9a-z]+)/?$ public.php?action=manage&upload_id=$1&key=$2 [L,NC]
    RewriteRule ^myfiles(/(.*))?$ myfiles.php?folder=$1 [L,NC]
    RewriteRule ^upload(/(.*))?$ upload.php?upload_to=$1 [L,NC]
    RewriteRule ^members/?$ browse.php [L,NC]
    RewriteRule ^members/([0-9]+)/?$ browse.php?page=$1 [L,NC]
    RewriteRule ^members/public/?([0-9]+)?/?$ browse.php?public=1&page=$1 [L,NC]
    RewriteRule ^members/info/([0-9]+)$ browse.php?action=info&userid=$1 [L,NC]
    RewriteRule ^members/browse/([0-9]+)/?(/.+)?$ browse.php?action=browse&userid=$1&folder=$2 [L,NC]
    #RewriteRule ^([a-z0-9\_]+)/?$ browse.php?action=browse&username=$1 [L,NC]
    
     
  6. White Stormy

    White Stormy Take that, subspace!

    Joined:
    Sep 17, 2002
    Messages:
    85,485
    Likes Received:
    69
    Location:
    Sparkopolis
    I was getting another error that was fixed by enabling gd on the host.. it was trying to use gd for watermarks

    now it works no probs :bigok:

    [​IMG]

    [​IMG]
     

Share This Page