HELP please!

Discussion in 'OT Technology' started by flip24, May 14, 2006.

  1. flip24

    flip24 Active Member

    Joined:
    Jan 5, 2006
    Messages:
    8,709
    Likes Received:
    1
    Location:
    San Antonio
    i dropped my Moto A630 in water a while back. :crying: tryin to get it working again. the bottons dont really work (off anf on again) but the screens and camera do. Any sugestions
     
  2. DINide

    DINide New Member

    Joined:
    Sep 30, 2003
    Messages:
    15,530
    Likes Received:
    0
    Location:
    Chi Town
    you should have taken the battery out and air dryed it for a few days. moto phones usually work fine after being in water if you let it dry for few days. sorry
     
  3. OFI

    OFI New Member

    Joined:
    Apr 6, 2006
    Messages:
    52,607
    Likes Received:
    0
    Location:
    Wet Wales
    yea its pretty screwed i dropped my phone in the toilet while it was on and it vibrated it self into a death i took the battery out and dried it best i could although it booted up again and i was able to get basic functions for a while the mic didnt work.. and then it refused to charge even after buying a new battery
     
  4. flip24

    flip24 Active Member

    Joined:
    Jan 5, 2006
    Messages:
    8,709
    Likes Received:
    1
    Location:
    San Antonio
    ill try kept it in my car for a while to get the phone hot but didnt really work
    but sounds like it will work
     
  5. flip24

    flip24 Active Member

    Joined:
    Jan 5, 2006
    Messages:
    8,709
    Likes Received:
    1
    Location:
    San Antonio
    sucks mine will charge and turn on buttons are just off and on alot
     

Share This Page