HELP! CD player works, radio does not

Discussion in 'OT Technology' started by EB, Sep 13, 2006.

  1. EB

    EB 2/24/08

    Joined:
    May 25, 2006
    Messages:
    22,022
    Likes Received:
    0
    Location:
    TEXAS
    I haven't driven my truck in a couple mounths, and I am getting it ready to go tailgating this weekend. I went to start it up and the radio isn't working, but the cd player works fine.

    It is an '82 Chevy Silverado with an after market Sony xplode CDX-C5000X cd player. I checked the connector on the windshield to make sure it was plugged in (antenna in the windshield) and I checked all the fuses, and everything seems fine. Does anyone have an idea what could be wrong.

    Something like this happened to one of my father's cars, but it turned out to be a blown fuse. I'm stumped since all the fuses look fine.
     
  2. EB

    EB 2/24/08

    Joined:
    May 25, 2006
    Messages:
    22,022
    Likes Received:
    0
    Location:
    TEXAS
    No one? :dunno:
     
  3. JRock10

    JRock10 Active Member

    Joined:
    May 25, 2005
    Messages:
    7,751
    Likes Received:
    0
    Location:
    Nashville, TN FTW
    when you switch from CD to radio, does the unit shut off completely or just no sound? do you have amps in this system or just deck and speakers?
     
  4. EB

    EB 2/24/08

    Joined:
    May 25, 2006
    Messages:
    22,022
    Likes Received:
    0
    Location:
    TEXAS
    Just deck and speakers. When I go to tuner, it goes like normal but all it does is play static. When I use push the seek button, it just goes forever.
     
  5. JRock10

    JRock10 Active Member

    Joined:
    May 25, 2005
    Messages:
    7,751
    Likes Received:
    0
    Location:
    Nashville, TN FTW
    check the antenna connection on the back of the radio. if still nothing, metra makes a small powered antenna box that plugs into the antenna on the radio and 12v+. this little thing works great! IIRC the part # is something like AN-GR20
     

Share This Page