Hard Drive cant support > 4GB

Discussion in 'OT Technology' started by Enforcer, Dec 2, 2003.

  1. Enforcer

    Enforcer New Member

    Joined:
    Aug 30, 2003
    Messages:
    224
    Likes Received:
    0
    I just bought a 200GB external maxtor hard drive and when i try to rip a dvd into an ISO onto the drive, i get write error as soon as the ISO gets to 4 GB.
    Is there a way to configure a hard drive to support over 4 GB?

    Thanks
     
  2. jrmy

    jrmy Guest

    is it an older computer?say more than 5-6 yrs?
     
  3. wax

    wax Guest

    make sure the drive is formatted in ntfs and not fat32
     
  4. Zourn

    Zourn 16-bit Ninja OT Supporter

    Joined:
    Apr 3, 2002
    Messages:
    2,354
    Likes Received:
    0
    Location:
    Texas
    this probably has more to do with ASPI drivers. I don't know that much about them, but i know when i open up a DVD ripping tool, it syas that unless i get an updated ASPI driver i can' read more than 2GB's at a time or something.
     
  5. Enforcer

    Enforcer New Member

    Joined:
    Aug 30, 2003
    Messages:
    224
    Likes Received:
    0
    new computer. 2.4 P4. 512 DDR.

    I know that my c: drive is FAT32, but i'm not sure what the maxtor external drive is.
    I'll look into ASPI drivers and see what i find.

    Thanks
     
  6. cmsurfer

    cmsurfer ºllllllº

    Joined:
    Jun 6, 2003
    Messages:
    5,079
    Likes Received:
    0
    Location:
    NJ
    You should be fine with FAT32 or NTFS, even though I vote for NTFS. The drive should have came with software so the computer can set it up and recognize the correct size of the drive.

    I recently bought a Maxtor 160 gig internal drive. I had to use the software (Maxblaster) to set it up so my PC would recognize it as the full 160 gig.

    HTH.
     
  7. 5Gen_Prelude

    5Gen_Prelude There might not be an "I" in the word "Team", but

    Joined:
    Mar 14, 2000
    Messages:
    14,519
    Likes Received:
    1
    Location:
    Vancouver, BC, CANADA
    Sounds like you're having a problem with the file being too big, not the HD. FAT32 only supports 4 GB files
     
  8. Zourn

    Zourn 16-bit Ninja OT Supporter

    Joined:
    Apr 3, 2002
    Messages:
    2,354
    Likes Received:
    0
    Location:
    Texas
  9. SLED

    SLED build an idiot proof device and someone else will

    Joined:
    Sep 20, 2001
    Messages:
    28,118
    Likes Received:
    0
    Location:
    AZ, like a bauce!
    hmmmm are you sure you aren't thinking about regular FAT? I knew it was an issue with that FS, but FAT32 should be fine. I have quite a few files over 4 gb. NTFS just adds the security factor to the FAT32 file system, same basic internals i believe.
     
  10. drewski_amk

    drewski_amk Guest

    no, fat32 maxes out a 4gb. what you are thinking of is that fat16 has a 4gb limit on PARTITION size, not file size, while fat32 has a 2tb limit on partition size, with the same 4gb limit on file size
     
  11. 5Gen_Prelude

    5Gen_Prelude There might not be an "I" in the word "Team", but

    Joined:
    Mar 14, 2000
    Messages:
    14,519
    Likes Received:
    1
    Location:
    Vancouver, BC, CANADA
    And FAT has a file limit of 2 GB FYI.
     
  12. Supadoggie

    Supadoggie I ♥ my doggah

    Joined:
    May 22, 2000
    Messages:
    32,484
    Likes Received:
    0
    Location:
    NYC
    run in cmd ( command prompt)

    convert %driveletter%: /FS:NTFS

    that should convert your drive to NTFS and fix the problem
     
  13. Enforcer

    Enforcer New Member

    Joined:
    Aug 30, 2003
    Messages:
    224
    Likes Received:
    0
    thanks guys. the conversion of the file system to NTFS did the trick. Thanks for the command supadoggie. I owe you one.
     
  14. Achance007

    Achance007 Active Member

    Joined:
    Oct 12, 2000
    Messages:
    16,134
    Likes Received:
    5
    Location:
    New Castle, DE
    i have problems with my external no name drive getting delayed/fail write errors too when trying to transfer large files using firewire, but if I use USB 2.0 it goes smoothly. But the reason I don't leave it using USB 2.0 is because I can't start up with the drive on because the computer tries to recongize it as a boot up drive and gives me an error. But if I start up with firewire its ok. I looked in the bios but I don't see a setting to turn off USB start up.
     
  15. Igneous

    Igneous \\ OT Supporter

    Joined:
    Sep 19, 2003
    Messages:
    5,462
    Likes Received:
    20
    Location:
    The Empire State
    your drive is probably fat32 or something. you must convert your drive to ntfs if you want to have single files over 4GB, fortunately you dont need to format you drive to convert it to ntfs you can do it from cli on run. type "convert C:\ /FS:NTFS", replace C:\ with your driveletter.
     
  16. 5Gen_Prelude

    5Gen_Prelude There might not be an "I" in the word "Team", but

    Joined:
    Mar 14, 2000
    Messages:
    14,519
    Likes Received:
    1
    Location:
    Vancouver, BC, CANADA
    Wow that was brilliant :eek2:
     

Share This Page