A&P HALP ME! Canon Dig. Rebel 300D giving Error 02

Discussion in 'Lifestyle' started by cdscowboy, Jan 29, 2008.

  1. cdscowboy

    cdscowboy New Member

    Joined:
    Jun 16, 2004
    Messages:
    2,181
    Likes Received:
    0
    Location:
    Corvallis, OR
    So I just got this camera off eBay, and was reportedly new and it came with everything except the battery, which I got in a seperate auction.

    Got it all charged up, formatted the CF card using the included card reader. When I go to power it on, it says "EOS" on the display, followed by "Error 02".

    The manual says this is an issue w/the CF card, but I've tried another CF and it didn't help at all...same error message. I've obviously tried removing/reinserting the card and battery...nothing.

    Anyone else have the same problem? Fixes?
     
  2. JordanClarkson

    JordanClarkson OT Supporter

    Joined:
    Oct 11, 2002
    Messages:
    59,945
    Likes Received:
    15
    Location:
    Go Dodger Blue!
    is it a canon battery or another brand?
     
  3. isaac86hatch

    isaac86hatch This thread sucks

    Joined:
    Oct 3, 2005
    Messages:
    27,892
    Likes Received:
    0
    Location:
    Oregon
    your CF card is fuxord. Re-format it USING THE CAMERA, not your computer.
     
  4. isaac86hatch

    isaac86hatch This thread sucks

    Joined:
    Oct 3, 2005
    Messages:
    27,892
    Likes Received:
    0
    Location:
    Oregon
    btw, if that does not work, you need a new CF card.
     
  5. cdscowboy

    cdscowboy New Member

    Joined:
    Jun 16, 2004
    Messages:
    2,181
    Likes Received:
    0
    Location:
    Corvallis, OR
    It's another brand of battery - some chinese thing - but if I don't have the card it, it'll power up, take photos...just doesn't store them.

    How do I format on the camera? If the card is in there, it won't let me do anything.

    Also, there's a pin that looked halfway bentish...annnnnd I'm a dumbfuck and tried to straighten it. It broke. Me ftl. :wtc:
     
  6. Spurious

    Spurious New Member

    Joined:
    Jan 15, 2006
    Messages:
    27,219
    Likes Received:
    0
    Location:
    Houston, Texas Bans: 5
    In the camera or the flat pins on the card?
     
  7. cdscowboy

    cdscowboy New Member

    Joined:
    Jun 16, 2004
    Messages:
    2,181
    Likes Received:
    0
    Location:
    Corvallis, OR
    Bent pin in the camera. Card reader pin, if I'm not wrong.

    My card has no external pins.
     
  8. Spurious

    Spurious New Member

    Joined:
    Jan 15, 2006
    Messages:
    27,219
    Likes Received:
    0
    Location:
    Houston, Texas Bans: 5
    Oh. Yeah, you're fucked.
     
  9. JordanClarkson

    JordanClarkson OT Supporter

    Joined:
    Oct 11, 2002
    Messages:
    59,945
    Likes Received:
    15
    Location:
    Go Dodger Blue!
    return that shit
     
  10. Spurious

    Spurious New Member

    Joined:
    Jan 15, 2006
    Messages:
    27,219
    Likes Received:
    0
    Location:
    Houston, Texas Bans: 5
    .

    He clearly knew it was defective.
     
  11. cdscowboy

    cdscowboy New Member

    Joined:
    Jun 16, 2004
    Messages:
    2,181
    Likes Received:
    0
    Location:
    Corvallis, OR
    Yeah :wtc: I contacted Canon to see if I can get a replacement card reader, or at least the pins. I'm good at soldering, and I've taken cameras apart before, so I can fix it...just sucks cause I want it now!

    Wahhhh!
     
  12. isaac86hatch

    isaac86hatch This thread sucks

    Joined:
    Oct 3, 2005
    Messages:
    27,892
    Likes Received:
    0
    Location:
    Oregon
    link to original?
     
  13. cdscowboy

    cdscowboy New Member

    Joined:
    Jun 16, 2004
    Messages:
    2,181
    Likes Received:
    0
    Location:
    Corvallis, OR
    Hah...I wish.
     
  14. cdscowboy

    cdscowboy New Member

    Joined:
    Jun 16, 2004
    Messages:
    2,181
    Likes Received:
    0
    Location:
    Corvallis, OR
    :o Actually I had no idea. The auction said it was brand new and never used. My guess is that it was either a floor model or someone messed up the pin and returned it without using it. It's a very clean camera, no scratches or anything anywhere.
     
  15. nastyboy132

    nastyboy132 New Member

    Joined:
    Aug 17, 2004
    Messages:
    1,509
    Likes Received:
    0
    aids


    sry.
     
  16. Spurious

    Spurious New Member

    Joined:
    Jan 15, 2006
    Messages:
    27,219
    Likes Received:
    0
    Location:
    Houston, Texas Bans: 5
    He... as in the guy who sold it.
     
  17. cdscowboy

    cdscowboy New Member

    Joined:
    Jun 16, 2004
    Messages:
    2,181
    Likes Received:
    0
    Location:
    Corvallis, OR
    Ahh...perhaps. Funny thing is though, the auction didn't list the CF card in the package deal, so I wonder if they even opened the camera at all. It was a 1GB card, worth a few extra bucks. So I dunno...they're one of those setups that sell your stuff on eBay if you bring it to them...they just might sell stuff as-is and not even look at it.

    :dunno:

    Talked to Canon today. Great customer service, btw. The card reader for the unit was a whopping $7.34 + $6 shipping, so I just bought it. I'll fix it myself. I'll be in touch with that seller though :squint:
     

Share This Page