A&P Fuck, my on camera flash on my 20D won't pop up

Discussion in 'Lifestyle' started by Kirk Hinrich, Jul 6, 2008.

  1. Kirk Hinrich

    Kirk Hinrich New Member

    Joined:
    Sep 20, 2004
    Messages:
    40,492
    Likes Received:
    0
    Location:
    Brown Line
    I really don't know how long this has been broken. I tried to use my pop up today and the fucker doesn't even spring up or respond. Its like the camera isnt even trying to pop it up. I wouldn't really care but my plan was to sell my 20d soon to finance a 40d. Fuck.
     
  2. White Stormy

    White Stormy Take that, subspace!

    Joined:
    Sep 17, 2002
    Messages:
    85,489
    Likes Received:
    70
    Location:
    Sparkopolis
    it's doing you a favor.. buy a 580ex ii
     
  3. White Stormy

    White Stormy Take that, subspace!

    Joined:
    Sep 17, 2002
    Messages:
    85,489
    Likes Received:
    70
    Location:
    Sparkopolis
    right as you wanted to sell... ouch.
     
  4. MSIGuy

    MSIGuy om nom nom nom!

    Joined:
    May 30, 2005
    Messages:
    4,724
    Likes Received:
    0
    Have you tried gently prying up on the flash while you press the pop up button? Maybe a slight ammount of force could get it to pop up like it's supposed to.

    Does it give you any error message or click at all even?
     
  5. MSIGuy

    MSIGuy om nom nom nom!

    Joined:
    May 30, 2005
    Messages:
    4,724
    Likes Received:
    0
    It is pretty much amazing, I love mine.
     
  6. ace3

    ace3 mouthify my wang.

    Joined:
    May 4, 2001
    Messages:
    122,602
    Likes Received:
    7
    Location:
    Omaha NebrASSka Posts: 15
    look inside the hot shoe ... the pin switch is probably stuck in the 'down' position, making the camera think there's something attached to the shoe.

    get a little knife or screwdriver out and pry it up.

    happened on my xti all the time.
     
  7. Kirk Hinrich

    Kirk Hinrich New Member

    Joined:
    Sep 20, 2004
    Messages:
    40,492
    Likes Received:
    0
    Location:
    Brown Line
    :cool: will try this in an hour and report back
     
  8. mobbarley

    mobbarley Active Member

    Joined:
    Mar 4, 2005
    Messages:
    9,256
    Likes Received:
    2
    Location:
    Sydney
    yeah check the hot shoe, the pin should be very small and under one of the rails of the hot shoe - dont try prying one of the conductors.
     
  9. Kirk Hinrich

    Kirk Hinrich New Member

    Joined:
    Sep 20, 2004
    Messages:
    40,492
    Likes Received:
    0
    Location:
    Brown Line
    fuck, the hole in there is just to small to get anything into, I dont know how to like pop it back up
     
  10. Kirk Hinrich

    Kirk Hinrich New Member

    Joined:
    Sep 20, 2004
    Messages:
    40,492
    Likes Received:
    0
    Location:
    Brown Line
    fuck i see no pin under the rails
     
  11. mobbarley

    mobbarley Active Member

    Joined:
    Mar 4, 2005
    Messages:
    9,256
    Likes Received:
    2
    Location:
    Sydney
  12. mobbarley

    mobbarley Active Member

    Joined:
    Mar 4, 2005
    Messages:
    9,256
    Likes Received:
    2
    Location:
    Sydney
    scroll down
     
  13. Kirk Hinrich

    Kirk Hinrich New Member

    Joined:
    Sep 20, 2004
    Messages:
    40,492
    Likes Received:
    0
    Location:
    Brown Line
    K i got the plate off, but I dont have my little set of screwdrivers here to loosen the screws, have to take care of this later
     

Share This Page