WEB Flash embedding

Discussion in 'OT Technology' started by 4thgenceli, Sep 9, 2008.

  1. 4thgenceli

    4thgenceli Active Member

    Joined:
    Mar 5, 2005
    Messages:
    2,229
    Likes Received:
    0
    I don't know WTF I did wrong. I used Flash maker to create my .swf, along with a HTML file, a java, and other necessary files.

    http://media.ourlewisfamily.net/test/myalbum/intro_flash.swf
    http://media.ourlewisfamily.net/test/myalbum/myalbum.html

    Both of those work as expected. In Dreamwever (CS3), I try to embed the .swf into my index.htm document, but I just get a 'Load Fail' error. Any advice on why?

    http://media.ourlewisfamily.net/test/index.htm


    Now yesterday, when I was playing around with the idea it worked perfectly (the embedded flash via Dreamweaver in the index.htm file and it played).
     
  2. 4thgenceli

    4thgenceli Active Member

    Joined:
    Mar 5, 2005
    Messages:
    2,229
    Likes Received:
    0
    For reference, here's the code from the index file.

    Code:
    ***Snip header***
    <script src="Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
    ***Snip header***
    
    <script type="text/javascript">
    AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','800','height','600','title','intro_flash','src','myalbum/intro_flash','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movie','myalbum/intro_flash' ); //end AC code
    </script>
      <noscript>
      <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="800" height="600" title="intro_flash">
        <param name="movie" value="myalbum/intro_flash.swf">
        <param name="quality" value="high">
        <embed src="myalbum/intro_flash.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="800" height="600"></embed>
      </object>
      </noscript>
    
     
  3. biawokauns

    biawokauns New Member

    Joined:
    Sep 18, 2001
    Messages:
    19,893
    Likes Received:
    0
    Location:
    Republic of Kalifornia
    google swfobject
     
  4. kingtoad

    kingtoad OT Supporter

    Joined:
    Sep 2, 2003
    Messages:
    55,924
    Likes Received:
    11
    Location:
    Los Angeles
    .
     
  5. 4thgenceli

    4thgenceli Active Member

    Joined:
    Mar 5, 2005
    Messages:
    2,229
    Likes Received:
    0
    Hrm.... hope it's as easy as they make it to be (only my 2nd site I've made).
     
  6. kingtoad

    kingtoad OT Supporter

    Joined:
    Sep 2, 2003
    Messages:
    55,924
    Likes Received:
    11
    Location:
    Los Angeles
    Easier than the shit you're doing, plus it degrades gracefully.
     
  7. 4thgenceli

    4thgenceli Active Member

    Joined:
    Mar 5, 2005
    Messages:
    2,229
    Likes Received:
    0
    DOH...


    Goddamn directory structures. Load fail was due to the swf not being able to locate the content (xml, pictures, etc). It was looking in the root site directory (when I thought it would just look in it's own directory since i linked it from there).

    Moved everything to root directory, and she's happy now.
     
  8. kingtoad

    kingtoad OT Supporter

    Joined:
    Sep 2, 2003
    Messages:
    55,924
    Likes Received:
    11
    Location:
    Los Angeles
    I hope you still decided to use swfObject.
     
  9. 4thgenceli

    4thgenceli Active Member

    Joined:
    Mar 5, 2005
    Messages:
    2,229
    Likes Received:
    0
    Yeah I am. Just wanted to first get over the fail load problem, which i did. Have that thing in there now. Lot less code than to use dreamweaver's insert function.
     
    Last edited: Sep 9, 2008

Share This Page