Emission Tests Failed P0507 v.GMC Jimmy 98

Discussion in 'OT Driven' started by forgotmyname, Jun 11, 2009.

  1. forgotmyname

    forgotmyname Active Member

    Joined:
    Jul 18, 2007
    Messages:
    13,959
    Likes Received:
    0
    So...we have a 98 Jimmy that has done nothing but break and break.
    Latest update was that it didn't pass emissions.
    They replaced the O2 Sensor but the light is still on. Autozone guy told us to drive the cars for around 60miles and the light will go away.

    Is this true? What else (of the millionth things could be wrong?)

    One of the things I've found out, vacuum leak and cat replacement.
     
  2. Valafar

    Valafar Active Member

    Joined:
    Dec 20, 2001
    Messages:
    1,013
    Likes Received:
    0
    Location:
    Landers
    Yup. Some of the OBD II items run their test after X miles so it's a true test when the engine is at operating temp.
     
  3. mtnbikekid08

    mtnbikekid08 Aime-moi moins, mais aime-moi longtemps

    Joined:
    Jul 31, 2007
    Messages:
    3,549
    Likes Received:
    0
    Location:
    San Jose
  4. ldaggerl

    ldaggerl New Member

    Joined:
    Feb 24, 2009
    Messages:
    924
    Likes Received:
    0
    Could have reset the code and I believe that causes the tests to start again instantly. I did that with my car and it worked fine.
     
  5. ldaggerl

    ldaggerl New Member

    Joined:
    Feb 24, 2009
    Messages:
    924
    Likes Received:
    0
    yes if you reset the codes the tests should start again almost instantly. The tests do happen after X amount of miles.
     

Share This Page