dd-wrt wireless client-bridge...

Discussion in 'OT Technology' started by raand, Jan 17, 2010.

  1. raand

    raand New Member

    Jan 17, 2008
    Likes Received:
    I have been working at using

    -DD-WRT third party FW on a Linksys WRT54G V8.0 as a client bridge(client)
    -and a Linksys WRT54G2 with standard release firmware as the primary wireless router(host)

    I have used the set up on the dd-wrt wiki and forum and cannot seem to get it to work... I currently seem to be getting an IP on my laptop connected to the client from the DHCP on the host, but cannot connect to the outside my LAN. I also seem to be getting as my default gateway on my laptop, although it is set to the host's ip in the dd-wrt settings.

    I have attempted multiple set up instructions and have reached the same result every time.

    I used this set up for one of the attempts

    I have already disabled IPV6
    I have also tried running with no encryption and I do not get better results
    I am currently using WPA2 Personal for secutiry settings

    I am running Vista on the laptop
    the host is a WRT54G2 with standard FW
    the Client is a WRT54G with dd-wrt FW v24

    Anyone dealt with this set up before and have some advice?
  2. Chris

    Chris New Member

    Oct 27, 2003
    Likes Received:
    Texas on my mind
    I have it running just fine for my non-wifi-having PS3. All of the relevant settings that need to be setup are on the second router. Once you have your primary router running properly you dont need to change any settings on it to make client bridge work. They used to say start with lower or no security and then bump it up once you have it working but I didnt even bother doing it that way.

    The instruction on the wiki should be all you need, but off the top of my head the few showstoppers I can remember from my setup are make sure your second router has a static IP that is in the same IP range as your primary router but also make sure it doesnt have the same address. If your primary router is make the second router or something like that. Then make sure DHCP is turned off on the second router and make sure the SPI firewall is turned off on the second router.

    So, do a factory reset on the second router and work through the wiki, and post here again.

    Also, it might help to set a static IP for the computer you are using to configure the second router. Set the static IP to something outside of the normal DHCP range, so if you havent adjusted DD-WRT's defualt DHCP settings something like should work

Share This Page