Clock issue v.BootCamp

Discussion in 'OT Technology' started by kamikaze, Jun 13, 2007.

  1. kamikaze

    kamikaze Active Member

    Joined:
    Jan 30, 2005
    Messages:
    33,629
    Likes Received:
    0
    Location:
    Barrie Ontario
    Ok, so I installed Vista in Boot Camp, and it keeps buggering up my clock in OS X...what friggin setting can I use in Vista to keep the time right in both OS's

    ibWTFVista :ugh2:
     
  2. dbman96

    dbman96 Active Member

    Joined:
    May 25, 2000
    Messages:
    49,996
    Likes Received:
    6
    happens with XP too. dunno what to tell you, it's a pain in the ass.
     
  3. xenon supra

    xenon supra OT Supporter

    Joined:
    Feb 3, 2005
    Messages:
    33,675
    Likes Received:
    0
    Location:
    San Diego, CA
    they better fix this shit in leopard
     
  4. kamikaze

    kamikaze Active Member

    Joined:
    Jan 30, 2005
    Messages:
    33,629
    Likes Received:
    0
    Location:
    Barrie Ontario
    yea, i know it happened in XP too, cause I ran it in Boot Camp before Vista...I'd really like to get this figured out
     
  5. kamikaze

    kamikaze Active Member

    Joined:
    Jan 30, 2005
    Messages:
    33,629
    Likes Received:
    0
    Location:
    Barrie Ontario
    Ok, after some dicking around with this, I think I've got it. Oh, and I don't know if this will work in XP, I'm pretty sure I tried to fix it then too and never got it to go. Also, before you start, make sure OS X is set to the proper time zone and set to update the clock from the internet.

    Boot into Vista.
    Disable the Internet Time Sync
    Set the Time Zone to GMT (Casablanca, etc)
    Set the clock to the current time.

    Reboot into OS X, the clock should say the right time.

    Reboot back into Vista
    Clock will likely be wrong at this point
    Set time zone back to the proper setting for your area, in my case it was GMT -05:00 Eastern Time USA and Canada
    Time in Vista should now be correct.

    Now i've booted into both OS's a couple of times now, and everything seems to be ok. Also, I'm not sure if the reboot into OS X in the middle of that proceedure has any effect on the outcome at all, but those were the exact steps I took. Oh, and if you re-enable the internet time sync in Vista it'll get all fucked up again.

    If someone would be so kind as to test this out to see if it actually works or if I just got lucky.

    :bigthumb:
     
  6. dbman96

    dbman96 Active Member

    Joined:
    May 25, 2000
    Messages:
    49,996
    Likes Received:
    6
    I'll give it a shot on XP and see if that works. :x:
     
  7. dbman96

    dbman96 Active Member

    Joined:
    May 25, 2000
    Messages:
    49,996
    Likes Received:
    6
    This SEEMS to have worked.

    Thanks for the tip!

    I actually tried this once before but either I forgot to disable the internet time sync in windows, or I missed the reboot in between.
     
  8. kamikaze

    kamikaze Active Member

    Joined:
    Jan 30, 2005
    Messages:
    33,629
    Likes Received:
    0
    Location:
    Barrie Ontario
    Who knows lol

    Maybe that reboot in the middle is necessary, i really dunno. I think it has to do with OS X storing the time in the BIOS as the actual GMT time and then applying the correction based on the time zone selected in the time and date properties, where XP/Vista wants to store the local time in the BIOS :dunno:

    I remember running into this alot when dual booting with Linux and 2000/XP boxes so maybe it's a *NIX thing :dunno:
     
  9. dooks88

    dooks88 need some bat wings

    Joined:
    Oct 25, 2004
    Messages:
    645
    Likes Received:
    0
    Location:
    SRQ
    Great find. This clock shit really annoyed me.
     
  10. P07r0457

    P07r0457 New Member

    Joined:
    Sep 20, 2004
    Messages:
    28,491
    Likes Received:
    0
    Location:
    Southern Oregon
    probably has to do with how windows likes to store times as if local and unix generally likes to store in gmt.
     

Share This Page