A&P CG Card Error (xti v 50d???)

Discussion in 'Lifestyle' started by swagisserious, Jan 21, 2010.

  1. swagisserious

    swagisserious New Member

    Joined:
    Jan 2, 2010
    Messages:
    152
    Likes Received:
    0
    CF Card Error (xti v 50d???)

    hey team, i need some help/suggestions...

    currently i have been shooting with a xti for over about 6months, swagisserious.wordpress.com

    the CF card i am currently using is a 1gb simpletech cf card, i upgraded to a 4gb sandisk but for some reason my camera wont read the card. tried the 4gb sandisk on my friends camera and it worked fine. bought a few more cf cards and it did not read them either. double checked the updated firmware, (1.1.1) but was not able to update it plus the camera had already been updated tto its most recent update, finally, i called canon support and they said the repair would cost around 198 (190 + 8 return shipping). they also offered a "canon loyalty" program where i can trade in my xsi and get a 50d body for 669 (refurb). 90 Days Refurbished Camera Limited Warranty for the 50D. if i go the repair route, it would take 10-14 days from day of shipping the camera to receiving it.

    side note, the 198 could always go up, that is the base quote they give

    thoughts/suggestions?
     
    Last edited: Jan 21, 2010
  2. isaac86hatch

    isaac86hatch This thread sucks

    Joined:
    Oct 3, 2005
    Messages:
    27,892
    Likes Received:
    0
    Location:
    Oregon
    Have you tried formatting the card in the camera? I'm assuming you can't if the camera will not read them. Also, does the original 1GB card still work?
     
  3. swagisserious

    swagisserious New Member

    Joined:
    Jan 2, 2010
    Messages:
    152
    Likes Received:
    0
    yea i reformated the camera in P mode, the camera only reads the 1gb simpletech cf card, i double checked all the pins under the light, all pins are intact and non bent, it wont read any other cf cards though...:eek3:
     

Share This Page