CEL - engine guys quick question please

Discussion in 'OT Driven' started by whippet_1, Jan 17, 2006.

  1. whippet_1

    whippet_1 Active Member

    Joined:
    Feb 6, 2005
    Messages:
    17,039
    Likes Received:
    0
    Location:
    T dot
    [FONT=verdana, arial, helvetica, sans-serif]Hey guys. Just wondering if i could get some opinions. I don't notice any problems driving my 97 cx Hatch with a 1.6 B16a1 transplant. (bought it around aug 05) Anyway, recently during regular driving the CEL light comes on (either while idling or just cruising on the hwy) anyways, the light remains on while the car is on, but when i turn the car off and back on, the light goes off. It will remain off for a couple of days, then suddenly it will come on again when im driving randomly...and the process repeats itself.

    Not sure if this is in regards to a sensor, but has anyone experienced something like this before? To get the best diagnosis, should I have it hooked up, cuz really if it's not causing a problem, i'm not sure if i wanna drop cash down to fix it. Any help would be appreciated. Thanks
    [/FONT]
     
  2. LS1S13

    LS1S13 New Member

    Joined:
    Jun 26, 2005
    Messages:
    12,782
    Likes Received:
    0
    Get it scanned. Why wouldn't you?
     
  3. whippet_1

    whippet_1 Active Member

    Joined:
    Feb 6, 2005
    Messages:
    17,039
    Likes Received:
    0
    Location:
    T dot
    Well at the moment it's not something that i can just make appear. It's suually off and comes on rrandomly...can it be scanned even when it's off?
     
  4. LS1S13

    LS1S13 New Member

    Joined:
    Jun 26, 2005
    Messages:
    12,782
    Likes Received:
    0
    Yes, OBD2 stores the codes even when the CEL isn't on.
     
  5. Eclipsed830

    Eclipsed830 Active Member

    Joined:
    Jul 7, 2005
    Messages:
    39,507
    Likes Received:
    0
    Location:
    San Francisco/Cleveland
    Even if the code is off, it still stores the code in the OBDII mode 3.
     
  6. whippet_1

    whippet_1 Active Member

    Joined:
    Feb 6, 2005
    Messages:
    17,039
    Likes Received:
    0
    Location:
    T dot
    Well the eng is OBD1 while the car's wiring harness is OBD2..it
    uses an adaptor to connect the 2...i'll try to find somewhere to scan it for now
     

Share This Page