CDROM Problem

Discussion in 'OT Technology' started by Culex, Apr 7, 2006.

  1. Culex

    Culex New Member

    Joined:
    Sep 27, 2005
    Messages:
    51
    Likes Received:
    0
    Location:
    New Jersey
    About 2 weeks ago, my CDROM drive stopped showing up in "My Computer". It is stilled being read by my computer (i can find it in the device manager, but it has the yellow ! next to it), but it cant be accessed. It says im missing my drivers, but i can't find drivers anywhere. If anybody knows what to do/has drivers for my CDROM it would be much appreciated:)

    The manufacturer is (Standard CD-ROM driver), the type is ATAPI DVD DD 2x16x4x16.
    The exact error is: Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19).

    Thank you in advanced :):)
     
  2. cmsurfer

    cmsurfer ºllllllº

    Joined:
    Jun 6, 2003
    Messages:
    5,079
    Likes Received:
    0
    Location:
    NJ
    You can try to delete it from device manager and then let it re-detect itself.

    I've have never needed CD-ROM drivers. I've always just plugged them in and Windows took care of the rest.
     
  3. Yep

    Yep Knick knack paddy whack, give the old dog a bone

    Joined:
    Jan 22, 2001
    Messages:
    4,603
    Likes Received:
    0
    Location:
    South Jersey
    That should do the trick.
     
  4. Culex

    Culex New Member

    Joined:
    Sep 27, 2005
    Messages:
    51
    Likes Received:
    0
    Location:
    New Jersey
    I just tried that, and it gave me the wrong message. I downloaded Daemon Tools to create virtual drives and try that, but my computer cant read them either. I dont think it can read CDROM drives at all anymore for some reason.
    I also tried an old CDROM drive i had around (that does work), but it wouldnt detect that either, so its definatley a problem with my computer. Im thinking maybe its the ribbon.

    Any ideas?
     
  5. JaJae

    JaJae New Member

    Joined:
    Mar 22, 2004
    Messages:
    5,987
    Likes Received:
    0
    Try a different ribbon?
     
  6. cmsurfer

    cmsurfer ºllllllº

    Joined:
    Jun 6, 2003
    Messages:
    5,079
    Likes Received:
    0
    Location:
    NJ
  7. chips

    chips ...

    Joined:
    May 2, 2004
    Messages:
    3,755
    Likes Received:
    0
    Location:
    Phoenix, AZ
  8. Culex

    Culex New Member

    Joined:
    Sep 27, 2005
    Messages:
    51
    Likes Received:
    0
    Location:
    New Jersey
    I went to the link, but my comp does not have the copy of the file they are looking for...
    I deleted what i thought was the file, and i cant open my device manager now.....gg me???
     
    Last edited: Apr 7, 2006
  9. chips

    chips ...

    Joined:
    May 2, 2004
    Messages:
    3,755
    Likes Received:
    0
    Location:
    Phoenix, AZ
    did you try the reg hack i suggested?
     
  10. Culex

    Culex New Member

    Joined:
    Sep 27, 2005
    Messages:
    51
    Likes Received:
    0
    Location:
    New Jersey
    I did, but i screwed it up. Funny story: i screwed up and tried to correct it by restarting. But i think the files i accidentally deleted were important to the startup, but i got that fixed. Anyway, im gonna try it correctly this time.
     
  11. Culex

    Culex New Member

    Joined:
    Sep 27, 2005
    Messages:
    51
    Likes Received:
    0
    Location:
    New Jersey
    woot, i just fixed it. Thanks for all the help
     
  12. mdaniel

    mdaniel S is for Shiksa

    Joined:
    May 6, 2000
    Messages:
    52,504
    Likes Received:
    315
    Location:
    Northwest Mejicooooooo
    Ahh, the infamous upper filters/missing optical drives. If you ever have problems with itunes (or itunes breaking other stuff in your PC) the fix posted from Microsoft works on that too.
     

Share This Page