car shutting down randomly

Discussion in 'OT Driven' started by nwmrkt, Jun 22, 2008.

  1. nwmrkt

    nwmrkt New Member

    Joined:
    Dec 31, 2004
    Messages:
    2,254
    Likes Received:
    0
    Location:
    Ontario, Canada
    Hey, I have a problem with my car shutting down randomly...its a s13 240sx with a s14 ka24de. The car shuts randomly (not all the time) when im slowing down. It dies slowly (like im running out of fuel?). Its defenitly not a battery problem. All lights, etc work. When I crank the car that works fine but the car just won't start. But again, it would be able to start up again after a bunch of tries.


    Thanks
     
    Last edited: Jun 23, 2008
  2. Dweezil

    Dweezil New Member

    Joined:
    Jun 5, 2008
    Messages:
    123
    Likes Received:
    0
    Location:
    at altitude
    What is a "s14 kade"?
     
  3. Rich

    Rich New Member

    Joined:
    Jun 26, 2007
    Messages:
    5,225
    Likes Received:
    0
    Location:
    Orlando, FL
    Motor. He meant to say KA24DE.
     
  4. nwmrkt

    nwmrkt New Member

    Joined:
    Dec 31, 2004
    Messages:
    2,254
    Likes Received:
    0
    Location:
    Ontario, Canada
    yeah sorry, this is not a s-chassis forum haha.
     
  5. nwmrkt

    nwmrkt New Member

    Joined:
    Dec 31, 2004
    Messages:
    2,254
    Likes Received:
    0
    Location:
    Ontario, Canada
    anyways i was told it could be a dirty fuel filter?
     
  6. Dweezil

    Dweezil New Member

    Joined:
    Jun 5, 2008
    Messages:
    123
    Likes Received:
    0
    Location:
    at altitude
    Are you using an oiled K&N? Got any datalogs of MAF voltage? I just recently upgraded my car, and turned my OEM MAF into a blow-through. Due to the IC plumbing bends just before and after the MAF housing, I have some funky idle issues.

    On some other car I had long ago, I over-oiled the K&N, and some of the oil gunked up the MAF. A bath in brake cleaner fixed me right up.

    And sure - it could be a plugged fuel filter. Lots of miles on the car?
     
  7. aCab

    aCab New Member

    Joined:
    Jun 1, 2007
    Messages:
    18,292
    Likes Received:
    0
    Location:
    Chicaaago
    Sounds like a fuel issue - clean out the throttle body and if you can, the injectors. Also, check the fuel filter.
     
  8. nwmrkt

    nwmrkt New Member

    Joined:
    Dec 31, 2004
    Messages:
    2,254
    Likes Received:
    0
    Location:
    Ontario, Canada
    thanks for the help guys, just to "make sure", to go about cleaning the throttle body? And I have no clue on the injectors haha. I also checked the fuel filter...can't really see anything really threw those small holes on each side?

    Also a update on the symptoms...again it happens randomly. As in today, i was driving along and the car died "slowy". I tried downshift rev matching whatever i could do but no fuel, nothing, was delivered when i pressed on the gas. Instead the car just engine braked, but more like "half" engine brake, "half" dieing slowly.

    Then after all that the car will turn back on after the a couple or alot more tries when cranking.

    Thanks again
     
  9. monaroCountry

    monaroCountry New Member

    Joined:
    Nov 14, 2003
    Messages:
    342
    Likes Received:
    0
    spark plugs
     

Share This Page