car audio ?---subs pop when amp powers off

Discussion in 'OT Technology' started by psykosis, Apr 28, 2008.

  1. psykosis

    psykosis Go placidly amid the noise and the haste

    Joined:
    Oct 31, 2001
    Messages:
    123,840
    Likes Received:
    157
    Location:
    Listing between sin and salvation
    Just had a Clarion 920eq installed yesterday. Now, when the car is turned off, the subs make a solid thump/pop when the amp powers off. What the hell is causing that, and how the hell do I fix it?
     
  2. tjamz

    tjamz New Member

    Joined:
    Nov 12, 2007
    Messages:
    605
    Likes Received:
    0
    wire a small capacitor inline with the Remote Turn-on wire to the amp, that way it will slowly shut off the amps
     
  3. psykosis

    psykosis Go placidly amid the noise and the haste

    Joined:
    Oct 31, 2001
    Messages:
    123,840
    Likes Received:
    157
    Location:
    Listing between sin and salvation
    :bigthumb:
     
  4. deusexaethera

    deusexaethera OT Supporter

    Joined:
    Jan 27, 2005
    Messages:
    19,712
    Likes Received:
    0
    That's a normal effect. A good amp will disconnect the speakers before shutting off. There must be something weird going on with yours.
     
  5. psykosis

    psykosis Go placidly amid the noise and the haste

    Joined:
    Oct 31, 2001
    Messages:
    123,840
    Likes Received:
    157
    Location:
    Listing between sin and salvation
    shit amp, but here's what the deal was:

    My Clarion 920eq was wired wrong, so it never powered off. Had it rewired and now there is a very minimal pop, apparently due to the fact that the eq powers off just a tic slower than the deck, sending a bit more signal to the amp. Now the subs very lightly click (sounds like a padlock opening). I can live w/ that for now.
     

Share This Page