Car audio crew, HELP v. popping sound

Discussion in 'OT Technology' started by Zz_3.14_zZ, Jan 14, 2007.

  1. Zz_3.14_zZ

    Zz_3.14_zZ New Member

    Joined:
    Nov 5, 2003
    Messages:
    23,308
    Likes Received:
    0
    Location:
    Mid-Flolriduh
    Ok, I have a fosgate 400.4 that have have been using for the longest time. It was working fine. I was pushing four components and two subs with it.

    Yesterday I picked up a 500.2 to run the subs. I install it, it goes in great. If fucking hits hard...but now I have a popping sound (rather loud too) coming from the components.

    I have changed the ground, pos, RCA's raw speaker wires. Nothing stops it.

    What can I do to fix this?!?!!
     
  2. delussional77

    delussional77 Active Member

    Joined:
    Jan 1, 2005
    Messages:
    3,782
    Likes Received:
    0
    Location:
    Overland Park, KS
    when does the popping sound occur?

    if you hit your brakes or change the radio controls does it pop? or just randomly?

    If it pops randomly then i'd suggest grounding your rca's (yes, you can do it ...look it up).

    Are you splitting the RCA's to send signals to both amps or are you using two sets from the HU to both amps?
     
  3. Zz_3.14_zZ

    Zz_3.14_zZ New Member

    Joined:
    Nov 5, 2003
    Messages:
    23,308
    Likes Received:
    0
    Location:
    Mid-Flolriduh
    Oh, lol maybe I should tell you that it happens when I change track, album turn the headunit off switch to radio, CD or AUX.

    I am running one set of RCA's for each amp.
     
  4. delussional77

    delussional77 Active Member

    Joined:
    Jan 1, 2005
    Messages:
    3,782
    Likes Received:
    0
    Location:
    Overland Park, KS
    ground your head unit (don't just use the ground provided by the harness, it's not sufficient)

    99% of the time this is the cause
     

Share This Page