Can't get Dolby Digital or DTS sound from receiver.

Discussion in 'OT Technology' started by terminator1010, Jun 15, 2003.

  1. terminator1010

    terminator1010 Eld

    Joined:
    Dec 23, 2001
    Messages:
    4,891
    Likes Received:
    0
    Location:
    Hordanes Land
    My receiver won't detect Dolby Digital or DTS input. It says PCM is being input no matter which dvd I try. I've tried DVD's with DD and DTS. Right now I am using my PS2 as a DVD player. I am using the toslink connection for the audio. I have heard that it can ouput Dolby digital at least, but im not sure, can anyone confirm this? I can get sound, just not DD or DTS. I've tried all the settings on my receiver. Is my receiver messed up? I did buy it used. It is an Onkyo TX-SR600. Thank in advance.
     
  2. thegeneral

    thegeneral Guest

    you need to switch your digital audio output settings on the PS2 (through the menu) right now you have it outputting in PCM which you want to switch to DD

    try that
     
  3. TurboDerek

    TurboDerek My favorite meal is horsemeat and rice.

    Joined:
    Jul 13, 2001
    Messages:
    1,465
    Likes Received:
    0
    Location:
    San Bernardino
    Are you at the DVD menu? Most DVD's don't activate the Dolby Digital or DTS until the movie starts. Also check the lanaguage menu
     
  4. terminator1010

    terminator1010 Eld

    Joined:
    Dec 23, 2001
    Messages:
    4,891
    Likes Received:
    0
    Location:
    Hordanes Land
    In the PS2 menu, all I see is clock adjustment, screen size, digital out (on/off I have this set to on), component video out, and language. I see no option for setting PCM or DD output.
     
  5. terminator1010

    terminator1010 Eld

    Joined:
    Dec 23, 2001
    Messages:
    4,891
    Likes Received:
    0
    Location:
    Hordanes Land
    I tried them when the movie was playing, and I checked the language/audio set up menu and made sure it was set to either DD 5.1 or DTS.
     
  6. 04

    04 Guest

    Go to the setup menu when there isnt a disc in the drive. IIRC you cant get the digital output format to change with a disc in the drive.
     
  7. terminator1010

    terminator1010 Eld

    Joined:
    Dec 23, 2001
    Messages:
    4,891
    Likes Received:
    0
    Location:
    Hordanes Land
    I was trying that without a disk in the drive. Do you own a PS2? Have you personally changed it? If so please give me step-by-step instructions because I sure as hell can't change it. I tried GTA:vice city and turned on the DTS and to my surprise, my receiver detected it. So the receiver is capable of detecting it, then I tried the DVD's and it still said PCM. So I think that it can only pass the DTS signal in games and not DVD's. Maybe something to do with the DVD driver.
     
  8. 04

    04 Guest

    I don't own a PS/2, no. But I had to fix my cousin's awhile back. We figured it out eventually without the manual, so if you can find the manual online, it should help...

    And yes, it can pass at least DD and probably DTS too for movies....
     
  9. terminator1010

    terminator1010 Eld

    Joined:
    Dec 23, 2001
    Messages:
    4,891
    Likes Received:
    0
    Location:
    Hordanes Land
    Ok, I finally figured it out. I was using the menu that comes up when you turn on the PS2 without a disk in. This menu only alows you to turn on the optical digital out. But to turn on DTS and DD you need to go to the setup screen accessed by putting in a DVD, pressing select and selecting SETUP. Its all working perfect now. I'm glad my receiver isn't messed up as I originall though. Thanks for all the help.
     

Share This Page