ATI Catalyst 7.4

Discussion in 'OT Technology' started by KoopaTroopa, May 14, 2007.

  1. KoopaTroopa

    KoopaTroopa OT Supporter

    Joined:
    Jun 3, 2004
    Messages:
    4,661
    Likes Received:
    0
    Location:
    Fall River, Mass
    I downloaded ATI's newest driver, 7.4, for my Radeon 9550/X1050 and it freaking sucks. I have a dual monitor setup, but when I play a video on my primary monitor through DVI, no video, just audio. When I move the window to my secondary monitor on VGA, it works fine. I thought it was something else at first & spent all weekend, but it was the crappy driver. Even 7.3 does the same thing. I had to go back to 7.1; caused me problems all weekend.

    I'm going to buy a new computer soon, so...should I get a nvidia or ATI brand video card??
     
  2. P07r0457

    P07r0457 New Member

    Joined:
    Sep 20, 2004
    Messages:
    28,491
    Likes Received:
    0
    Location:
    Southern Oregon
    gee, an ATi thread complaining about drivers. Who woulda thunk???


    nVidia or bust.
     
  3. Doc Brown

    Doc Brown Don't make me make you my hobby

    Joined:
    Mar 31, 2006
    Messages:
    16,404
    Likes Received:
    0
    Location:
    Ohio
    I can sympathize with ATI.
    It must be a bitch to have good drivers that will work with all your cards.
    But right now nVidia has it down-pat.

    I'm running a 7900GT card, and I never even bothered downloading newer drivers for it. The ones that came on the cd work perfectly.
     
  4. KoopaTroopa

    KoopaTroopa OT Supporter

    Joined:
    Jun 3, 2004
    Messages:
    4,661
    Likes Received:
    0
    Location:
    Fall River, Mass
    The only reason I bought this ATI card was because I got it for $11 at Staples, normally $100, after coupons & discounts.

    I had a nVidia card before this & it worked great. With this ATI card, kinda giving me problems.
     
  5. deusexaethera

    deusexaethera OT Supporter

    Joined:
    Jan 27, 2005
    Messages:
    19,712
    Likes Received:
    0
    Christ dude, maybe the fact that you bought an old POS dime-bin card is affecting performance. Or maybe the fact that you're using two cards that are totally dissimilar. If you want two monitors, just hook them both up to your X1050.
     
  6. Create

    Create :free at last:

    Joined:
    Jan 4, 2006
    Messages:
    8,043
    Likes Received:
    2
    It's not at all uncommon to have to use drivers one, two, or even three versions back with ATI products.

    I can't tell you why but I know that I have ten times the stability issues with ATI products than with nVidia.
     
  7. D1G1T4L

    D1G1T4L Active Member

    Joined:
    May 4, 2001
    Messages:
    16,489
    Likes Received:
    0
    Location:
    Bay Area
    i have x800 gto^2
    got latest drivers.....works fine 4 me
     
  8. deusexaethera

    deusexaethera OT Supporter

    Joined:
    Jan 27, 2005
    Messages:
    19,712
    Likes Received:
    0
    x800 is a different card.
     
  9. KoopaTroopa

    KoopaTroopa OT Supporter

    Joined:
    Jun 3, 2004
    Messages:
    4,661
    Likes Received:
    0
    Location:
    Fall River, Mass
    I never said I had two cards plugged in. I'm using the X1050...I kinda figured since there are two ports on the back, that I could use them for dual monitors instead of using 2 video cards. Maybe I'll try to jam the VGA cable into the S cable port.
    But thanks for the tip about plugging the monitors in 1 card instead of using 2 different cards at the same time. Maybe I'll hook the really crappy card back in & try dual monitors that way.
    Who the hell would use 2 different brand cards at the same time??
     
  10. Tvan

    Tvan New Member

    Joined:
    Jun 21, 2006
    Messages:
    9,012
    Likes Received:
    0
    Location:
    Chicago
    :gtfo:
     
  11. Create

    Create :free at last:

    Joined:
    Jan 4, 2006
    Messages:
    8,043
    Likes Received:
    2
    Absolutely nothing wrong with it so long as it's not part of an SLI/Crossfire set.
     
  12. deusexaethera

    deusexaethera OT Supporter

    Joined:
    Jan 27, 2005
    Messages:
    19,712
    Likes Received:
    0
    I mistook the bit about "drivers for my X1050/9550" as meaning you had both cards.

    Run DriverCleaner to remove any and all video drivers on your system, then reinstall 7.4.
     
  13. P07r0457

    P07r0457 New Member

    Joined:
    Sep 20, 2004
    Messages:
    28,491
    Likes Received:
    0
    Location:
    Southern Oregon
    if you can't take the truth, you're the one that needs to :gtfo:
     
  14. deusexaethera

    deusexaethera OT Supporter

    Joined:
    Jan 27, 2005
    Messages:
    19,712
    Likes Received:
    0
    I never had a problem with ATi drivers. I thought they were stepping on the software that auto-rotates my LCD, but when I got an nVidia card it does the same thing, so :dunno:.
     

Share This Page